GuzzleHttp error

Describe the issue or problem
Error 500 when open admin page

Steps I took leading up to the issue
For example:

  1. Go to ‘administration page’
  2. See error 500

What application are you using?
Php 7.4.13
Apache 2.4.6

Additional information
Please add any screenshots, logs or other information we can use to investigate this problem.
Fatal error: Uncaught GuzzleHttp\Exception\ConnectException: cURL error 6: Could not resolve host:; Unknown error (see in /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php:200 Stack trace: #0 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(155): GuzzleHttp\Handler\CurlFactory::createRejection() #1 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(105): GuzzleHttp\Handler\CurlFactory::finishError() #2 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlHandler.php(43): GuzzleHttp\Handler\CurlFactory::finish() #3 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/Proxy.php(28): GuzzleHttp\Handler\CurlHandler->__invoke() #4 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/Proxy.php(51): GuzzleHttp\Handler\Proxy::GuzzleHttp\Handler{closure}() #5 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/PrepareBodyMiddleware.php(37): Guzzl in /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 200

Hello Ragil

Seems like the server of your journal cannot connect to domain.
You can try to ping on you server and if it is get connection loss, you should contact the server administrator to whitelist the domain.

OJT Team

Are you using a multi-journal ADS system?
Could you disable the “plugin update manager” and check again please?

i’m not using that plugin

how to resolve that?

Dear @ragil_nurhawanti

You can check firewall setting on your server and related configuration in your server to allow external connection.

Better bet, I guess you discuss this issue with the server provider or server administration since it is not OJS issue but actually server config issue.


1 Like

I do have the same problem. There is no issue with the firewall. I tried the command
PING ( 56(84) bytes of data. it took forever. I tried from a different server without a firewall, again it did not work.

I would highly appreciate your support.