Good way to change the sender email address

howto
ojs3

#1

Dear All,

we are having a hard time to configure our OJS3.1 to get the sender of ALL emails to be the principal email address of the Journal. The documentation shows it is done that way: https://docs.pkp.sfu.ca/admin-guide/en/email
but we do have different sender on the mails. Is there a way to make ALL mails arrive from the primary email address, as it is written in the documentation?

Apart from that, how can we set who is signing the emails, and which email adresses are set in the reply-to? For instance, reviewers are reached by the section editors, but all automatic reminders are signed by the principle contact. We would like to change that too.


#2

The documentation here is slightly inaccurate with respect to the way OJS/OMP handle this. Currently OJS/OMP do not modify the From, but rather modify only the Envelope Sender, which is different. We anticipate this changing to match the documentation again based on the resolution of this issue:


#3

I’m not sure if I understood everything correctly, but following many links from what you sent, I found this one:


Could this be what I’m looking for?

Thanks,
Bogi


#4

This is a plugin which @ajnyga wrote to address this issue. The functionality there (or something very like it) will presumably be rolled into the core application in the future. In the meantime, installing and enabling this plugin should accomplish your goal.


#5

Just a note about the plugin that it needs the master branch version of mail.inc.php. I think it could be edited to use the current stable 3.1.1.4 version as well fairly easily (have not worked on it much since the feature is going to be there in the core soon).


#6

Thanks, I hope @mauser1 can solve the install, he cannot see the plugin yet in the list of plugins, although the install seemed to finish without a problem. Any advice to him?

Thanks,
Bogi


#7

Hi.

Ojs version: 3.1.1.2
Download:https://github.com/ajnyga/useGlobalSender master.zip

I create tar.gz and webinstall.

root@cyber://tesztcyber/plugins/generic#ls -al

drwxr-xr-x 3 www-data www-data 125 nov 13 16:39 useGlobalSender

files OK.
But I do not see it on the website.

SQL is OK!!
select * from versions;

| 1 | 1 | 0 | 0 | 2018-11-13 16:39:59 | 1 | plugins.generic | useGlobalSender | UseGlobalSenderPlugin | 1 | 1 |

I tried another plugin.
That’s all right.

I tried Apache reload, restart , and clear data cache.


#8

what is the folder name of the plugin on your installation? is it plugins/generic/useGlobalSender


#9
tesztcyber/plugins/generic# ls -al useGlobalSender/
összesen 28
drwxr-xr-x  3 www-data www-data  125 nov   13 16:39 .
drwxr-xr-x 23 www-data www-data 4096 nov   13 16:39 ..
-rw-r--r--  1 www-data www-data   49 nov   13 16:39 .gitignore
drwxr-xr-x  4 www-data www-data   30 nov   13 16:39 locale
-rw-r--r--  1 www-data www-data  299 nov   13 16:39 readme.md
-rw-r--r--  1 www-data www-data  502 nov   13 16:39 settings.xml
-rw-r--r--  1 www-data www-data 5468 nov   13 16:39 UseGlobalSenderPlugin.inc.php
-rw-r--r--  1 www-data www-data  609 nov   13 16:39 version.xml

#10

Do you still need another plugin?


#11

There is no php error when I list the plugins.


#12
mysql> select * from versions where product="useGlobalSender";
+-------+-------+----------+-------+---------------------+---------+-----------------+-----------------+-----------------------+-----------+----------+
| major | minor | revision | build | date_installed      | current | product_type    | product         | product_class_name    | lazy_load | sitewide |
+-------+-------+----------+-------+---------------------+---------+-----------------+-----------------+-----------------------+-----------+----------+
|     1 |     1 |        0 |     0 | 2018-11-16 11:26:25 |       1 | plugins.generic | useGlobalSender | UseGlobalSenderPlugin |         1 |        1 |
+-------+-------+----------+-------+---------------------+---------+-----------------+-----------------+-----------------------+-----------+----------+
1 row in set (0.00 sec)

mysql> select * from plugin_settings where plugin_name="useGlobalSender";
Empty set (0.00 sec)

BUT
tesztcyber/plugins/generic/useGlobalSender# cat settings.xml

<!DOCTYPE plugin_settings SYSTEM "../../../dtd/pluginSettings.dtd">
.....
<plugin_settings>
	<setting type="bool">
		<name>enabled</name>
		<value>true</value>
	</setting>
</plugin_settings>

#13

Hi @ajnyga,
could you help us please? The plugins seems to be installed, but there are no change in the emails, and the plugin does not appear on the plugins page. @mauser1 has put here the information about the install, if that helps.

Thanks in advance,
Bogi


#14

When you are trying to enable this plugin, are you logged in as the site administrator, or as a journal manager? I believe only the Site Administrator will have the ability to enable this plugin.


#15

We were trying to enable it as site administrator of course, but the plugin does not appear on the list.

Thanks,
Bogi


#16

@bog and @mauser1, have you resolved the discrepancy of @ajnyga’s comment here and your comment of the OJS version?

Ojs version: 3.1.1.2

Everything else seems to be correct.


#17

Hi,

It does require the master branch version of mail.inc to work, but I do not think it is the reason why it is not shown in the plugins listing. It should if it is under plugins/generic/ folder. Does it show if you check the site settings and the plugin listing there?

Disclaimer: the plugin itself is very experimental and not much tested!


#18

Hi!

Finally, our technicians solved the problem, and it works now! :slight_smile: The problem was that the plugin in the present form does not have the index.php file, so they have prepared one. You may consider including that in the plugin, so others can use it as well.

Thanks for the plugin, it works very well! :smiley:
Bogi


#19

oops, thanks.


#21

Dear All,

we have just found out, that the email_log table does not contains any of the new emails since we have installed the useGlobalSender plugin. Is that normal? Where can I see the emails then?

Thanks in advance,
Bogi