Fake user/Spam regestration

Hi Staff,

I found many fake user registered in our journal.
I read some suggestion to activate the captcha, I did as show in screenshot.
But, in the register form the captcha box is not appear.
Need help to avoid fake user/spam registration

thanks
Nayan

Hi @aiziqi,

which version of OJSare you using? From the screenshot it seems to be OJS 3.0.
The excerpt of your config contains setting for captcha which are not supported by OJS 3.0.
OJS 3.0 uses reCaptcha and this is the section in config.inc.php with the setting:
`;;;;;;;;;;;;;;;;;;;;
; Captcha Settings ;
;;;;;;;;;;;;;;;;;;;;

[captcha]

; Whether or not to enable ReCaptcha
recaptcha = off

; Public key for reCaptcha (see http://www.google.com/recaptcha)
recaptcha_public_key = your_public_key

; Private key for reCaptcha (see http://www.google.com/recaptcha)
recaptcha_private_key = your_private_key

; Whether or not to use Captcha on user registration
captcha_on_register = on`

Hope this helps

Claudia Jürgen

Hi Claudia,

Thanks for your hepl.
I got the key from google.
And it’s working now.

Nayan

This is my config.inc.php of OJS 3.0

[captcha]

; Whether or not to enable Captcha features
captcha = off

; Whether or not to use Captcha on user registration
captcha_on_register = on

; Whether or not to use Captcha on user comments
captcha_on_comments = off

; Whether or not to use Captcha on notification mailing list registration
captcha_on_mailinglist = off

; Font location for font to use in Captcha images
font_location = /usr/share/fonts/truetype/freefont/FreeSerif.ttf

; Whether to use reCaptcha instead of default Captcha
recaptcha = off

; Public key for reCaptcha (see http://www.google.com/recaptcha)
; recaptcha_public_key = my_key

; Private key for reCaptcha (see http://www.google.com/recaptcha)
; recaptcha_private_key = my_key

But still the recaptcha is not coming.

There is an error in the Javascript console of the browser.

Uncaught Error: Missing required parameters: sitekey(…)

Should I enclose the recaptcha keys with a double quote?

Please help.

You’ll need to register for a recaptcha key, and then configure that within config.inc.php. Note that the configuration options have changed between OJS 2.x and OJS 3.x. Many of the directives you list above are OJS 2.x only.

OJS 3.x directives include just:

Thanks, it worked :wink:

But when I submitted the form, I’m getting the following error, even though the reCaptcha was passed without any error:

Greetings,

I have a question too. Where is reCaptcha javascript coded? I want to change language by modifying this link:

<script type="text/javascript" async="" src="https://www.gstatic.com/recaptcha/api2/r20161206104336/recaptcha__en.js"></script>

to

<script type="text/javascript" async="" src="...recaptcha__uk.js"></script>

Ideally the language of reCaptcha should be one, the user had chosen from language toggle block (English or Ukrainian in my case). Maybe something like {if} statement.

@mithunjj, can you replicate this error consistently? Can you provide a public URL as an example?

The javascript reference is here:

We would need to translate between the PKP locales and the supported Google language codes:

@Vitaliy, would you be interested in sketching this out and sending in a pull request?

Greetings @ctgraham,

I am not very familiar with php for now, only javascript. Will see what I can do. And I am not very experienced with github, only committed changes to my personal repository by command line.

As I read the Google documentation, I note that this parameter is described as: “Optional. Forces the widget to render in a specific language. Auto-detects the user’s language if unspecified.”

Can you identify any reason Google’s autodetection of the language is not working properly?

Greetings @ctgraham,

Checked this issue once more. It seems that reCaptcha uses the browsers` language, but not html page language. I have installed Ukrainian language pack on Firefox and changed default language to it. After this manipulations reCaptcha language also have changed to this language. This mostly solves the problem for the authors, who not know English.

I’ve filed this as an enhancement request here:

2 Likes

Here is the link: http://journal.existentialpsychology.org/index.php?journal=ExPsy&page=user&op=register

Tried it from different IPs, but in vain. :confused:

One thing that is different about your config than most configs is that you are using disable_path_info. Is this due to current server limitations? Do have a way to test this in your current environment with disable_path_info as “Off”?

Set the disable_path_info to Off.

http://journal.existentialpsychology.org/index.php/ExPsy/user/register

But the problem still continues.:confused:

It seems to function correctly with respect to Google, and then fail validation within OJS. Have you made any changes to your OJS code? Are you running the latest stable OJS 3.0.1?

Version: 3.0.0.0

I haven’t made any changes to the code.

Can you replicate this problem in an upgrade or test install of OJS 3.0.1?