Errors updating 2.4.8 -> 3.1.1-4

Hi, I’m trying to update OJS but a bunch of errors appear:

Server Apache/2.4.29
PHP 7.2.10

(1)PHP Warning: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /var/www/html/ojs/lib/pkp/plugins/generic/usageEvent/ on line 386

(2) Double slashes (journals/2**//**articles/…)
[code: Installer Installer::removeReviewEntries]
WARNING: Unable to find a match for “135-324-1-RV.docx” in “files/journals/2//articles/135/”. Skipping this file.

(some more warnings like this)

(3) Maybe a consequence of (2)?
[data: dbscripts/xml/upgrade/3.0.0_preupdate.xml]
PHP Notice: Only variables should be assigned by reference in /var/www/html/ojs/lib/pkp/classes/db/ on line 122

(some more warnings like this)

(4)[code: Installer Installer::migrateArticleMetadata]
PHP Warning: Declaration of SubmissionLanguageEntryDAO::getByControlledVocabId($controlledVocabId, $rangeInfo = NULL) should be compatible with ControlledVocabEntryDAO::getByControlledVocabId($controlledVocabId, $rangeInfo = NULL, $filter = NULL) in /var/www/html/ojs/lib/pkp/classes/submission/ on line 20
(some more warnings like this)

(5) Stuck on [code: Installer Installer::migrateUserRoles]

Any help is welcome, thanks.