ERRORS occurred during installation, red hat Apache

Hi all, and thanks for your assistance in advance, I tried to install ojs-3.3 in my red hat server ( equipped with Apache/2.4.57 and MariaDB: MySQL Ver 15.1 Distrib 10.5.22-MariaDB, and PHP 8.0.30). but unfortunately i have a error message Errors occurred during installation
The directory specified for uploaded files does not exist or is not writable.
i created already the directory outside the path of my ojs (/var/www/html/ojs), and my directory was created in /home/userXX/files/ with the privilege: drwxrwxr-x. 2 apache apache , so it’s writable and apache:apache for user and group.
Then i edited my → files_dir = /home/userXX/files/ and this is the path used for installation /home/userXX/files , even I tried to give 777 as permission: drwxrwxrwx. 2 apache apache. **

Please don’t duplicate posts.

Thanks for your reply, but there are two different types of problems, the first issue was related to the major problem error 500 in my webpage after the uploading of my website from my localhost, so I wanted to check directly to download and install a testing version, but unfortunately I found a second error.
The two topics aren’t have the same subject.
Thanks again for your support.

Problem solved,
I disabled the selinux permissive mode using setenforce 0