Error with plugins in on line 46 | OJS

Hi! I’m trying to understand the reason behind an error pop-up that keeps appearing on my ojs. It has been two days since this pop-up appeared and I don´t know why. The only thing that happened prior to this error was that I was trying some plugins, which is most definitely the cause, but I’m not being able to find a way to solve it.

This is the error pop-up

And the error log
PHP Warning: include(/home/1/public_html/cache/fc-pluginSettings-2-crossrefexportplugin.php): Failed to open stream: No existe el fichero o el directorio in /home/1/public_html/lib/pkp/classes/cache/ on line 46
PHP Warning: include(): Failed opening ‘/home/1/public_html/cache/fc-pluginSettings-2-crossrefexportplugin.php’ for inclusion (include_path=‘.:/opt/alt/php80/usr/share/pear:/opt/alt/php80/usr/share/php:/usr/share/pear:/usr/share/php’) in /home/1/public_html/lib/pkp/classes/cache/ on line 46

PHP Warning: include(/home/1/public_html/cache/fc-pluginSettings-0-doiinsummaryplugin.php): Failed to open stream: No such file or directory in /home/1/public_html/lib/pkp/classes/cache/ on line 46
PHP Warning: include(): Failed opening ‘/home/1/public_html/cache/fc-pluginSettings-0-doiinsummaryplugin.php’ for inclusion (include_path=‘.:/opt/alt/php80/usr/share/pear:/opt/alt/php80/usr/share/php:/usr/share/pear:/usr/share/php’) in /home/1/public_html/lib/pkp/classes/cache/ on line 46

At first, I thought that the problem was with one specific plugin, but as the day went on the same error kept appearing with different plugins.

Also, the journal is on a shared hosting so I don’t have full access to the server.

Any idea? This error has stopped the production of the new issue since the popup doesn’t let the rest of the pages start properly. It’s starting to become a big problem. Please help!

Thanks in advance

Hi @Elizabeth_Leon
I recommend clearing the template cache and data cache and trying again.
You can find these options in the Administration section.

Hi @dagosalas, I’ve tried that already and the problem remains.

What version of PHP do you have?
Although OJS3.3.0.14 works with PHP 8 there are still some very small details especially if it is a migration from previous versions.
I would recommend you to try with PHP7.5, if it is not possible try with PHP 8.1.20 (not 8.0 or 8.2)

We are using the 8.0 version. I’m trying with the 8.1 version, but the problem persist.
I have tried to use this version previously, 8.1, but the page sometimes clashes and throws a 500 error. For now it’s working, as I can see the front, but if I open de ojs the error pop up is still there.

With the new PHP version, I keep getting this error. I’ve already tried a few solutions that were posted on other threads here but none has solved the error.

[08-Sep-2023 01:27:38 UTC] PHP Fatal error:  Uncaught Error: Class "IntlDateFormatter" not found in /home/saelorg1/public_html/lib/pkp/lib/vendor/php81_bc/strftime/src/php-8.1-strftime.php:60
Stack trace:
#0 /home/saelorg1/public_html/lib/pkp/lib/vendor/php81_bc/strftime/src/php-8.1-strftime.php(201): PHP81_BC\{closure}()
#1 [internal function]: PHP81_BC\{closure}()
#2 /home/saelorg1/public_html/lib/pkp/lib/vendor/php81_bc/strftime/src/php-8.1-strftime.php(180): preg_replace_callback()
#3 /home/saelorg1/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/plugins/modifier.date_format.php(84): PHP81_BC\strftime()
#4 /home/saelorg1/public_html/cache/t_compile/cecd5325a2f0fade12ceac8fff391e6ed433f547^ smarty_modifier_date_format()
#5 /home/saelorg1/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_template_resource_base.php(123): content_64fa02a12a0b68_90569979()
#6 /home/saelorg1/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode()
#7 /home/saelorg1/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_template.php(216): Smarty_Template_Compiled->render()
#8 /home/saelorg1/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(238): Smarty_Internal_Template->render()
#9 /home/saelorg1/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(134): Smarty_Internal_TemplateBase->_execute()
#10 /home/saelorg1/public_html/lib/pkp/classes/template/ Smarty_Internal_TemplateBase->display()
#11 /home/saelorg1/public_html/pages/index/ PKPTemplateManager->display()
#12 /home/saelorg1/public_html/lib/pkp/classes/core/ IndexHandler->index()
#13 /home/saelorg1/public_html/lib/pkp/classes/core/ PKPRouter->_authorizeInitializeAndCallRequest()
#14 /home/saelorg1/public_html/lib/pkp/classes/core/ PKPPageRouter->route()
#15 /home/saelorg1/public_html/lib/pkp/classes/core/ Dispatcher->dispatch()
#16 /home/saelorg1/public_html/index.php(68): PKPApplication->execute()
#17 {main}
  thrown in /home/saelorg1/public_html/lib/pkp/lib/vendor/php81_bc/strftime/src/php-8.1-strftime.php on line 60

Hi @Elizabeth_Leon,

You need to enable a module in your PHP configuration to resolve that error; see:

Alec Smecher
Public Knowledge Project Team

I’m trying, but this still doesn’t solve the first issue with the constant pop up that has basically frozen the rest of the functions

Hi @Elizabeth_Leon,

If you’ve resolved the problem with the missing IntlDateFormatter class by enabling the missing PHP module, and you’re back to encountering just the missing cache file problem, I’d suggest double-checking the file permissions in your cache directory. PHP needs to be able to create/delete/update files in that directory, and at a guess, I suspect it can’t.

Alec Smecher
Public Knowledge Project Team

Hello again! No, the upgrade hasn’t worked. The journal is on shared hosting so I don’t have full access to the server. I enabled it via cpanel but the error didn’t go away. And also the pop-up error persists.

I really don’t know what happened, everything was working fine until the popup appeared. I’ve already changed the files folder´s permissions, the cache folder, the public, and the plugin one, but nothing happened. Via phpmyadmin, I desactived most of the plugins, I have been searching for an error on the tables, but I’m still looking. I’m not really a professional in this field, so I’m running out of ideas.

If I upgrade the version of OJS, could that possibly fix the problem? We installed version a month ago and already have the next two issues in progress. I am willing to try anything to avoid reinstalling the entire OJS and losing all the work that has been done.

Hi @Elizabeth_Leon,

I don’t recommend further complicating things with an upgrade.

I wonder if we’re not chasing down the wrong problem. It’s possible that caching related errors are showing up in your error log without actually causing problems, but in the process, the relevant error message is getting buried among them. I’d suggest checking the error log immediately after you see the pop-up; you might find a relevant error message you’ve missed that way.

Alec Smecher
Public Knowledge Project Team