Error with CrossRef plugin list (probably due wrong data in articles)

Description of issue or problem I’m having:

On a quite big journal (120 issues, 3500 articles), in the import/export CrossRef plugin (last version), we can list all articles, but when we arrive to certain page… OJS does nothing and I got the following error in logs:

PHP Fatal error:  Uncaught Error: Call to a member function getId() on null in /var/www/html/controllers/grid/submissions/
Stack trace:
#0 /var/www/html/lib/pkp/classes/controllers/grid/ ExportPublishedSubmissionsListGridCellProvider->getCellActions(Object(Request), Object(GridRow), Object(GridColumn))
#1 /var/www/html/lib/pkp/classes/controllers/grid/ GridCellProvider->render(Object(Request), Object(GridRow), Object(GridColumn))
#2 /var/www/html/lib/pkp/classes/controllers/grid/ GridHandler->_renderCellInternally(Object(Request), Object(GridRow), Object(GridColumn))
#3 /var/www/html/lib/pkp/classes/controllers/grid/ GridHandler->renderRowInternally(Object(Request), Object(GridRow))
#4 /var/www/html/lib/pkp/classes/controllers/grid/ GridHandler->renderRowsInternally(Object(Request), Array)
#5 /var/www/html/lib/pkp/classes/controllers/grid/Gr in /var/www/html/controllers/grid/submissions/ 
on line 77, referer:

Wired part is listing works fine when is done via “Search” by issue number.
I mean, I listed every volume and I got no error from there.

What I tried to resolve the issue:

When listing with different number of items by page, error appear in more or less same range of articles (24 items > fails on page 25 and 26 / but with 10 rows > fails on pages 60, 61, 62).

Listing via “Search by issue” we resubmit to CrossRef all the articles, but error persists.

Application Version

OJS 3.1.2-4

Additional information, such as screenshots and error log messages if applicable:

I suspect the error is related with wrong article’s data (probably because it was uploaded via ojs native xml import/export plugin and not much filtering was applied and is not linked to an issue?) but I’m not sure about how to trace.

Hi @mar;
Hope you are doing fine. Were you able to solve that problem. If yes, Could you please share your steps because I’m facing same problem now.
Your help is highly appreciated,

Sorry for not posting the solution… if I recall well it was related with the PHP version. With 7.4 it fails but back to 7.2 it worked again.