Error on Upgrade to 3.1.2

Hi everyone,

I’m upgrading from 3.1.01 to 3.1.2. I followed the upgrade instructions. I’m using the web upgrade. When I hit the upgrade button, I get the following error:
Fatal error : require_once(): Failed opening required ‘plugins/importexport/users/’ (include_path=’.:/opt/cpanel/ea-php56/root/usr/share/pear’) in /our_web_pathl/ojs-3.1.2/lib/pkp/classes/plugins/ on line 470

Can anyone help me diagnose the root problem? I feel like I’m missing something basic and obvious. Thanks in advance.

Hi @ACastelletto,

The error states that file that’s required cannot be opened. This usually happens when there is a lack of permissions or the file is missing. The relative path to this file is lib/pkp/plugins/importexport/users/, can you check if it exists and permissions?

The file does exist. I did have some permission issues, but I fixed those and still get the same error. I’m curious about the include path listed in the error. That looks very off. Why is the ojs upgrade script looking there for the plugins files?

During upgrade OJS runs the script to update plugins’ database entries.

So, you have given permissions but the error is the same?
I’ve performed some debugging and in my case I have a call during the upgrade: to plugins/importexport/users/ that is successfully resolved. It appears after schemas update. Can you double check permissions, perform another update from the backup and post errors here?

I may be misreading your entry so bear with me. You’re saying there is or ought to be a table in the ojs database for plugins? Let me know if that’s right.

Yes, some plugins have own database entries in _settings tables or even own tables. The example of the latter: staticPages/schema.xml at 7afd90c6ab44a1665eaf199702fadadec4f094bc · pkp/staticPages · GitHub, here schema.xml file describes static_page table for the plugin.
Also all plugins have their version info specified in versions table.

Hey Vitaliy,
Thanks for your help. I’m still not there, but at least moving forward. One question I have is whether I’m trying to update too many versions ahead. Would this problem me remedied by doing incremental upgrades? Thanks again.

It shouldn’t be a problem.