Error: missing or invalid component

While uploading some files to ojs 3.0.0 I get this error.

this happend with a Word .doc file. I cannot upload this as article text…

other files work ok. also the filesize is fine.
What is the problem here?

I got this solved

This error as well as error described here:

resolved after I used the original config file ( from ojs 3.0.0 (with manual modifications).

So this problem occurs when using COPIED config file from 2.4.X

Well, apparently I still have this error.
So my previous message only resolved the image upload problem ,
But the doc file persists.
And it is only present in one .doc submission.

Hi @Wojciech_Francuzik,

The “component” is the part of the submission you’re uploading. There should be a pulldown list you can choose from – e.g. Article Text, Data Set, etc. Do you see that pulldown on the first step of the upload process?

Alec Smecher
Public Knowledge Project Team

I am working on OJS 3.0.0 - I also get this error message. I do see the dropdown menu to choose the component which I have chosen as Article Text. I still get the error message:


The file size is 105 kb so it can’ be that. Any suggestions?