Error installing ojs-3.3.0-14 plugin

I have successfully installed ojs-3.3.0-14 on a subdomain of an online cPanel host. (Of course, when I installed my database, I chose SQL by default and I don’t know if it is better to choose SQL or SQLI or etc…)
But when I try to install plugins online from the plugin gallery, I get the following error.

The uploaded plugin archive does not contain a folder that corresponds to the plugin name.

Please tell me step by step what to do? I have no knowledge of PHP, but I can find and replace the codes if I’m properly guided. I have read and checked many messages but I don’t know what exactly should I do?
Thank you very much for your patient and detailed answer, my good friends

In order to better master my own system, I will share the following essential information with you so that I can be guided better.


My OJS system information is in the link below.


My Server Information

------------------------------------------------------------------- settings in lib/pkp/controllers/page/




Select OAI setting during installation

Hi @hj_h

Which plugin have you tried to install? Is it happening to any plugin or a specific one?

If your server runs PHP7, it is recommended to use MYSQLI. You can change it on your file on the [database] section, driver parameter.



when I want to install any plugins I receive this error
My sever is using PHP version 7.4.33
I send you all information about server and My OJS.
Is there no need to change another value?

My OJS system information is in the link below.

thanks for answering :rose:

I changed this value in but, I still get the same error


Does the Apache process have access to the plugins directory and all its subdirectories? Apache group should have read access.

If you want to install a plugin from the gallery, you should temporarily give write access to the plugins/{category} directory of the plugin (most are generic plugins) for the Apache group.

1 Like

Which part should I use?
How can I check the access to the plugins/{category} directory of the plugin for the Apache group?

If there is no access, how can I activate it?
Please tell me step by step what to do?

(Let me tell you that I have given all user access to the database when I created the database. Is that what you mean?)

I apologize for asking you simple questions, because I have little knowledge in this field.

And again, thank you for your patience, dear friends

It’s in the file system, not in the database. Check there, please (probably you can do using cPanel, I don’t know this tool).

1 Like

Hi @hj_h

According to your system information, tar application is located in the follwoing path:

However, in your file , you haven’t adjusted the path to it yet.

Please, fix the path to your tar command and it should work installing plugins. You can double check the location of your TAR executable follwoing the instructions from this post:


1 Like

Hi @israel.cefrin
Thank you for your patient response and help

I replaced the following code that was in

tar = /bin/tar

with code

tar = /usr/bin/tar

I even replaced the following code which was in lib/pkp/controllers/page/


with code

echo file_get_contents($cachedFile);

I made the necessary changes, but the problem of not installing plugins, whether online from the plugin gallery or manually, still persists.

Hi @mpbraendle

If you know the folder path and give me its address, I will find it in my online host files and make the necessary changes.

files folder and folder are related to my magazine.
The main files of the OJS system are in and the name of the Journal DIrectory folder is files.

:point_down: :point_down: :point_down:

313 > plugins

1 Like

Hello my friend @mpbraendle
Thank you for taking the time for me.
I sent you this photo and entered the folder.
Which folder should I open and what should I do next?

Can anyone help me?
Some friends told me some solutions but the problem was not solved.
Please help, thank you