Error 404 on my OJS

Hi Im gettin a 404 error on my OJS, I tried to Install a new one but I get the same 404 error.
I can access any other file including wordpress and joomla installations
any idea?
Didnt change any setting on my server, Im totally lost as the only clue I have is this error_log:
[Wed Oct 21 12:48:58 2015] [error] [client] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20100525/’ - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/ cannot open shared object file: No such file or directory in Unknown on line 0
[Wed Oct 21 12:48:58 2015] [error] [client] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20100525/’ - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/ cannot open shared object file: No such file or directory in Unknown on line 0

any idea?

Hi @vleyrob,

Hmm, a 404 error is a file not found message coming from Apache, so it’s not even a PHP problem. Have you tried turning on the disable_path_info option in If that works, it’ll indicate that your Apache and PHP aren’t configured to use path_info-style URLs; there’s a FAQ entry about that.

Alec Smecher
Public Knowledge Project Team

1 Like

Hi Alec thanks for your reply

Yesterday I uploaded a copy of the entire site (files and DB) to another server It works perfect.
The question is why or how do I found the server configuration or settings that is in conflict with the OJS.
I uploaded a fresh new 2.4.7 OJS to install and Im getting the same 404 error, in the same server I have wordpress, joomla, osTicket and other sites working fine

thanks again

Hi @vleyrob,

Did you try my suggestion above?

Alec Smecher
Public Knowledge Project Team


disable_path_info = On

show_stats = On
show_stacktrace = On
display_errors = On

you can take a look here (this is a new installation 2.4.7):

It doesnt run the install process.

No problem opening any other file,
I tried changing the index.php content it displays well

It looks like your webserver is not recognizing index.php as the default document. In Apache, this could be caused by changing the DirectoryIndex or turning off Options Indexes.

Alternately, a rewrite rule could be mapping index requests away from index.php.

That’s not the problem ctgraham, if I change the OJS content index or just put a blank index.php it recognizes as default document and opens, my others CMS (Non OJS) are working well

Hello all,

I’m getting this 404 randomly. This started happening on this install after enabling the PKP PLN plugin. I reinstalled twice already.

The 404 just happened when trying to get to the Translation Plugin.
Error message:

404 Not Found

Stack Trace:

File: /var/www/ line 184
Function: Dispatcher->handle404()

File: /var/www/ line 134
Function: PKPPageRouter->route(Object(Request))

File: /var/www/ line 178
Function: Dispatcher->dispatch(Object(Request))

File: /var/www/ line 64
Function: PKPApplication->execute()

Hi @ramon,

Hmm – what is the URL you’re on when you see the 404? (You can remove the domain name from the URL if you like; I just need the portion after the index.php.

Alec Smecher
Public Knowledge Project Team

Hello Alec,

I’m sorry I didn’t save the URL, but the 404 started after enabling th PKP PLN plugin. I’m experiencing some strange network behaviour recently, so that may also be involved.

After enabling it, the first time the 404 happend was when clicking the configuration page of said plugin. Then, I reinstalled the system, because I couldn’t do anything else, The 404 spread out everywhere.

The second time it happened was on that new installation, when enabling then clicking the Translation plugin editing page.

After that, I downloaded a fresh OJS and reinstalled from scratch. So far, the 404 hasn’t happend yet, but I’m afraid of enabling the PKP PLN plugin for now. As soon as I have a general setup here, I’ll make a backup and enble it to see what happens.

Hello Alec,

Here’s an update:
I enabled the PKP PLN plugin and the error is actually a 500 server error.

The page being accessed is: /index.php/ciinf/*
Meaning, anything within a journal with that plugin enabled generates the same error. Admin pages are available.


Now, even after reinstalling and replacing the tables’s content with my backup, there are unavailble pages, generating the 500 error:


Here’s the server error log:

[Thu Nov 19 15:17:00 2015] [error] [client] ojs2 has produced an error\n  Message: WARNING: require_once(Archive/Tar.php): failed to open stream: No such file or directory\n  In file: /var/www/\n  At line: 32\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.4.45-0+deb7u2\n   Apache Version: Apache/2.2.22 (Debian)\n   DB Driver: mysql\n   DB server version: 5.5.46-0+deb7u1
[Thu Nov 19 15:17:00 2015] [error] [client] PHP Fatal error:  require_once(): Failed opening required 'Archive/Tar.php' (include_path='.:/var/www/') in /var/www/ on line 32

After commenting line 32 of ojs/plugins/generic/pln/lib/bagit.php ( //require_once 'Archive/Tar.php'; ), it was back on…

Hi @ramon,

Your server is missing the ZipArchive library required by the PLN plugin. Installation instructions are here:

Alec Smecher
Public Knowledge Project Team

How do I install this now??

A better installation link would be:

The thing is PHP is already installed.
I’m not an expert on Linux server setup…

System administration / php configuration questions are a bit off-topic for this forum. Google will point you toward some tutorials or Stack Exchange questions.

I will say, however, I would start by looking for available php-* packages in your distribution’s package manager (for example yum on RHEL or apt-get on Debian); then look at PECL and PEAR as alternate ways to add in the module if native packages are not available.

Hello all,

Happy to inform that the PLN Plugin is apparently working now, after installing the cUrl, ZipArchive AND TarArchive libraries.

It’s on the README, but who reads the README files before installing the server…

Is there a way to check if they are installed automagically? If so, shouldn’t plugins check for required libraries??

Hi all,

Tagging @mjordan, in case he wants to add this to his wish list.

Alec Smecher
Public Knowledge Project Team

@ramon, we’ve opened a Github ticket to check for the presence of those libraries you installed. Sorry for the trouble, and thanks for reporting the issue.


Hello @mjordan,

That’s the least we can do for you guys!
Provide any feedback that can help improve PKP Software.