Email sender address is wrong - OJS


I have this problem with Gmail SMTP-OJS configuration

Currently I have a magazine with OJS and other with OJS

I used the same SMTP settings in OJS and but “reply to:” / responder a: (in Spanish) does not appear in email sent from OJS

Email received from OJS

Email received from OJS

Is there any way to solve this problem OJS

Thanks for helping!!!

Hi @Jose_David_Alarcon_A,

For OJS 2.4.8 (and only that release), we always set “From” to the journal’s contact and “Reply-To” to the sender. For OJS 2.4.8-1, we went back to previous behavior, where “From” was the sender. This change and reversion were attempts to fix some long-standing problems people were having with OJS’s emails getting trapped in spam filters.

GMail’s SMTP service always rewrites the “From” address to the gmail account holder, which is why you’re seeing the behavior you describe. This behavior is specific to GMail’s SMTP service and doesn’t normally happen. If your ISP provides SMTP service, it’s probably a better idea to use that.

Alec Smecher
Public Knowledge Project Team

1 Like


Thank you very much for answering my English is very poor and that forces me to delay the answer.

It was hard work to get my emails reach the inbox (not spam) but finally solved in OJS

But now I have problems with … I’ve tried several ways and mails are classified as spam …

Is it possible to use the files that control mail “OJS” in “ OJS”?

If possible, what are the files that I move?


There are a lot of considerations in ensuring your messages are not flagged as spam. I discuss some of the technical considerations here:

My advice on the bottom of that post is your next step. Identify what part of email standards (SPF, DKIM, DMARC) is creating your spam problem, and you should be able to address it.

On the other hand, if you are sticking with Gmail as a sender, a shortcut for you might be to try setting’s force_default_envelope_sender to your Gmail address, and to use a proposed patch which will reintroduce the reply-to functionality.

1 Like

Hi! @ctgraham

wow… It is a big task but I will try … I need that mail function properly…

Thanks for help!!

Hi asmecher,

I have a really similar problem to Jose_David_Alarcon_A that I hoped you might be able to assist me with.

I’m running OJS version 2.4.8-1 and the reply-to field in e-mail sent from users via the OJS system is always overwritten as the ‘principle journal contact’ e-mail address and not the sender e-mail address. So at present when editors and authors want to correspond all their e-mail correspondence is being sent through the principle journal contact e-mail rather than back and forth between sender and recipient. The principle journal contact e-mail therefore has to forward e-mails back and forth between editors and authors like a go-between which is quite tedious.

As far as I understand, the upgrade to 2.4.8-1 should have stopped the reply-to field been overwritten but I seem to experience this issue.

I unfortunately don’t have access to the backend of the system but if you’re able to provide me with some potential solutions I can trouble shoot with my IT personnel I would be forever grateful. I have suggested an upgrade to OJS 3.0 however if this isn’t possible would setting up SMPT direct e-mail sending be useful?

Unfortunately I’m not super techy so excuse me if I appear to be asking simplistic questions and need some hand holding! It’s been challenging trying to wrap me head around some of these posts!! :sweat_smile:


Hi @JHE,

Are you using e.g. a GMail SMTP account in your OJS SMTP configuration?

Alec Smecher
Public Knowledge Project Team

Hi Alec,
Sorry for taking two years to get back to you regarding this. We had hoped an upgrade to OJS 3.0 would resolve this issue but unfortunately it’s still plaguing us. We do have Gmail STMP account in our OJS set up. The e-mail sent from the system reach their intended recipient but the reply to address is rewritten with the journal primary contact address (a g-mail address) which means all return correspondence never reaches the original sender.
At the risk of being annoying asking lots of questions back and forth - do you perhaps have some troubleshooting guidance specific to this issue that we can step through?
Thanks for your help!

Hi @JHE,

When you use the Gmail SMTP service, it forces the sender to the owner of the Gmail account; there’s unfortunately nothing you can do about that, as it’s under Google’s control.

More broadly, if you’re having trouble sending email with other SMTP servers, then you’re probably running into DMARC delivery issues. This is a standard that’s become widely used to prevent email spoofing. We’ve added improved support for DMARC-compliant emails in recent releases of OJS, and you might find some of the discussions of this useful in understanding what you can and can’t do without running afoul of DMARC compliance checks. See e.g. this thread: Unauthenticated email is not accepted due to domain's DMARC policy

In general, the newer the release of OJS you’re running, the less trouble you’ll have with it. (We’re due to release OJS 3.1.2-1 this week, in case you’re considering upgrading.)

Alec Smecher
Public Knowledge Project Team

1 Like

Thanks Alec! I’ll see how we go with trying a different SMTP and see if that helps in any way. Google is far too clever for its own good sometimes.