docxConverter plugin with OJS 3.2.1-1

Dear @Vitaliy,

I tested the docxConverter with the last OJS version 3.2.1-1, even if it is made for versions 3.1+ and get a Internal Server Error when I try to convert a .docx file. I tested in two different servers with the same error.

Captura de ecrã 2020-06-30, às 18.41.10

Have you tested yet the plugin or do you plan to upgrade to be compatible with the last version of OJS?


José Carvalho

Hi @josekarvalho,

It should work with 3.2+, are there any errors in PHP logs?

Hi @Vitaliy,

I manage to solve this!

The logs with warnings and a fatal error:
[01-Jul-2020 03:45:21 America/Los_Angeles] PHP Warning: Declaration of DocxToJatsPlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /home/jk_karona/ on line 0
[01-Jul-2020 03:45:21 America/Los_Angeles] PHP Warning: require_once(/home/jk_karona/…/docxToJats/vendor/autoload.php): failed to open stream: No such file or directory in /home/jk_karona/ on line 13
[01-Jul-2020 03:45:21 America/Los_Angeles] PHP Fatal error: require_once(): Failed opening required ‘/home/jk_karona/…/docxToJats/vendor/autoload.php’ (include_path=’.:’) in /home/jk_karona/ on line 13

I checked the line of the error and it ask for a file in the “docxToJats” folder inside the plugin files. This folder was empty. So I went to GitHub - Vitaliy-1/docxConverter: Plugin for OJS 3 that parses DOCX and converts it to JATS XML format, clicked on the folder of “docxToJats” (GitHub - Vitaliy-1/docxToJats at bd66ac39f471a5ff9b16f0a21993eaf5ba36869d), and copy this content to the plugin on the server.

Now it works. This issue is a consequence of using FTP to include the plugin. Is there any plans to include this plugin on the OJS Plugin Gallery?


José Carvalho

Glad that you’ve resolved it :slight_smile:

Yes, I plan to add it to the gallery in late autumn.

Nice! It will be easy for the community to test and use.