Designer sometimes has no rights to download files "The current role does not have access to this operation." [OJS]

Dear community,

in some cases our typesetter (OJS role “designer”) has no rights to download files in the “Production Ready Files” section. When he tries, the error message “The current role does not have access to this operation.” appears.


However, this error only occurs when I move the submission directly from the Copyediting to Production phase. If I download the post in Copyediting Phase and then upload it to Production phase, the typesetter is able to download it.

The file that the typesetter could not download was uploaded by the copy editor. The file that the typesetter could download was uploaded by the admin.

What could be the error?

Best regards,

@adm_sub When in the dashboard, go to Users & Roles > Roles, and you can see what stages that role has access to. Does the ‘designer’ role have access to the copyediting stage? I think by default they only have access to the production stage, which would explain why they can’t download files from the copyediting stage.

See here in the docs for more information: Users and Roles

Hi Michael, hi Kaitlin,

I guess this issue is related with the issue discussed here:

I think, this is not a feature (restricting user rights by roles), but a bug.

Best wishes


Hi @kaitlin and @aguen,

thanks for your answers!

I have already tried to grant the typesetter the rights for other production stages. Unfortunately, this did not work. I downloaded the file in my role as journal manager and uploaded it again. Afterwards the download for the typesetter worked. Therefore I also assume that this is a bug.

However, what does not work is to upload the file as a revision of an existing file. Obviously, this does not change the access rights.

I have looked at the thread that @aguen has linked and checked our database for “assoc_type” entries in the “submission_files” table. The files that could be downloaded (and previously uploaded by Journal Manager) have an empty “assoc_type” value. The files that could not be downloaded have an assoc_type of “520”.

In the meantime the bug has also appeared in the copyediting stage. The editor could not download a file that was attached to a discussion in the “Pre-Review Discussions” and was then forwarded to the copyediting stage.

Best regards,