Delivery Status Notification (Delay)


Our server is sending validation request emails like the one below to people/bots trying to subscribe:

Subject: Validate Your Account
To: vfrcbvbfysx vfrcbvbfysx

You have created an account with our journal, but before you can start using it, you need to validate your email account. To do this, simply follow the link below:


Thank you

In return, we are getting several of these messages a day:

Delivery incomplete
There was a temporary problem while delivering your message to Gmail will retry for 46 more hours. You’ll be notified if the delivery fails permanently.

450 4.2.1 The user you are trying to contact is receiving mail at a rate that prevents additional messages from being delivered. Please resend your message at a later time. If the user is able to receive mail at that time, your message will be delivered. For more information, please visit f13sor2732670qke.115 - gsmtp

I believe the message is because the bots that are trying to subscribe have overflown Gmail mailboxes and what not, but the question then is - can we turn on/off something in OJS that will save us from getting these messages?

Hi @Lolekbolek

A few suggestions. First, is recaptcha enabled for your journal? That will cut down on the number of bot registrations.

Second, are the accounts being created actually bot accounts? i.e. can you get a sense that they are just bots? If you know that legitimate accounts are being created and validated just fine then maybe use a different envelope address in your config file to prevent the delay notification messages from cluttering up your real inbox.


Thank you, @jnugent!

I just checked today and there were only two people in the past few weeks who managed to get past re-captcha that I enabled per your suggestion. So, we only got two emails in all this time as opposed to dozens per day that used to pester as before!

1 Like