Deactivation of Default Child Theme crashes my own child theme

Description of issue or problem I’m having:
I am relatively new to ojs and want to make my own child theme. So I downloaded the default child theme from GitHub, uploaded it to my server, duplicated the folder and started building my own child theme.
I got it to work and finally tried to deactivate the default child theme. But this crashed my own new child theme. It disappeared from the settings dropdown. And the frontend completely crashed/was white. Whenever I reactivated the default child theme everything worked again.
As a workaround I just typed bullets on the defaultChild folder (like: • defaultChild) and also in front of the file names (• Now this folder is still on the server. But everything works as expected. And the default child plugin does not show as plugin anymore.
I am a bit frightened this might crash sometime in the future again?
Please help – thanks!

Steps I took leading up to the issue:
Uploading the default child folder. Duplicating it. Building my own child theme. Deactivating default child theme – crash.

What I tried to resolve the issue:
Activating and deactivating, renaming files and folder, clearing template and data caches, changing xml settings in the theme folders.

Application Version - e.g., OJS 3.1.2:

Additional information, such as screenshots and error log messages if applicable:
My own new child theme is meant to override styles and templates of theme immersion.

1 Like