Cyrillic and Latin symbols in OJS

Does anyone solved the problem with Cyrillic and Latin symbols? The similar post can be found at Cyrillic symbols in contact name - #9 by Lazar_Stosic
After upgrading to OJS for some letter we have only symbols ‘’?’’. Manually cannot change it. After saving the letter again change to ?. It is the same with the title of article.
The sample of problem is presented bellow:

We tried manually to change symbol ‘’?’’, but after clicking on button Save the same back to ‘’?’’. There is no any error in error.log file.
Any idea?

Kind regards,

Hi Lazar,

What is the collation defined in your database structure?

The following query should display it:


Please, replace ojs_db_name in the query above with the actual database name.

Hi @janiosarmento,

thank you for assistance. Collation is defined as utf8_general_ci

I’m sorry for the belated reply!

Would you please paste your [database] section from Of course, needless to say, obfuscate your database credentials.

Also, what’s the version of MySQL you are using on your server, and what’s PHP version OJS is running under?

Thanks you for your reply.

driver = mysqli
host = localhost
username = xxxxxx
password = “xxxxxx”
name = xxxxx
; Set the non-standard port and/or socket, if used
; port = 3306
; unix_socket = /var/run/mysqld/mysqld.sock

; Enable persistent connections
persistent = Off

; Enable database debug output (very verbose!)
debug = Off

PHP version 7.4.16

What a mystery!

Although this is the default (by omission), please try adding this key to you, in [database] section:

collation = utf8_general_ci

If you try to view your data in MySQL CLI or in phpMyAdmin, are the data saved correctly in the database?

Yes, real mystery!
Previous I added collation = utf8_general_ci, but it is the same situation. I compared with previous settings in config.ini.php from old website and the settings are same. It is interesting that in the name and affiliation I have Cyrillic and Latin symbols, but in the references list have problems with some letters.
With red line is problematic letters (č, ć) and the same is correctly presented with green line (ž, š). It is really strange.
By the way, where exactly can check in phpMyAsmin if the data saved correctly in the database?

You should take a look at the user_settings table.

What are those two tables with latin1_swedish_ci collation?

In user_settings table all data are OK. The name and affiliation is without mistakes. Also, I wrote above that in the name and affiliation, on the website, the symbols are OK, but in the title, abstract, references are incorrect. For “locale” column everywhere is en_US.
I do not know how those two tables latin1_swedish_ci appear there.

Any idea? The problem still exist and on other journals.