CSS not working

Hello. I hope you can help me because no idea what to do.

I installed OJS 3.1.2-2, it is an installation not update.
Before installing it on the server I did a couple of tests on localhost and everything was perfect, without any problem.
But I uploaded the OJS folder (it is not a backup of the ones I have made local, it is clean) I have problems with the CSS. Already in the installation process no CSS appeared to me, a black screen with black letters. I installed it in case I could do something internally, but nothing.
In the browser console appears this error: [URL]/namejournal/$$$call$$/page/page/css?name=stylesheet net::ERR_HTTP2_PROTOCOL_ERROR 200
I have checked the file since the browser and it doesn’t appear empty.

What could be happening? Could you help me?

Hi @montse993,

It looks like the file cannot be accessed by the protocol specified.
Does this problem appear only in one browser?
Does turning off enable_cdn in config file solves the problem?
Are there any relevant errors in PHP logs or something suspicious in server access logs?

Thanks for your answer.
I have tried other browsers: Chrome, Opera, Edge and Firefox, and the problem continues.
I tried turning off enable_cdn, but it didn’t solve the problem.

I have made progress with my problem.
If I into the address https://domain.com, it doesn’t load the CSS and it shows the error HTTP2_PROTOCOL… . But if I into the address https://www.domain.com, it works perfectly.

Does anyone know the reason for this and how can I fix it?

Hmm, I would, 1) check if redirection is properly configured, 2) SSL certificates are OK (if you are using certbot it should be managed automatically for both domains, 3) check if force_ssl is enabled in config.inc.php, 4) check if DNS records for domain.com and www.domain.com are OK.

I’ve never encountered such an error before, so not sure…

I have similar problem on my site working on OVH hosting.

CSS is not loading with the following error:
Failed to load resource: net::ERR_HTTP2_PROTOCOL_ERROR

Was trying the above solutions but neither seem to work.

The problem is with loading the file:

The URL seems strange at least with $$$call$$$ in it, but it does work when inputted in the browser.


  1. add .htaccess with the following code:
SetEnv no-gzip 1