Create new version

I tried to use the new CREATE NEW VERSION feature for publishing our latest issue, and it didn’t work properly. I am wondering if perhaps I didn’t know how to use it properly. For each submission, I clicked create a new version. I uploaded the new page numbers, PDF, made any minor edits to titles, etc. Then I clicked SCHEDULE FOR PUBLICATION and selected the new issue. It seemed to work great. However, when we published the new issue, it didn’t show any page numbers and kept all the original versions of the articles. I also noticed that the original versions still appeared under In Press. When I looked further, all the published articles just said SCHEDULED under publication for the new version despite the fact that the issue was already published. I tried removing all the previously published versions from our In Press section, but then the new issue was empty (except for the editorial and one image that weren’t previously published). I tried unpublishing then republishing it, and it appeared to work. All the updated articles were in our new issue. However, I noticed that all the submissions from our new issue are still showing up In Press (so they are in two places now). When I click on an individual submission, it shows that version 1 is unpublished and version 2 is in the new issue. Do you know why they are appearing in both places? We only want them to be in the new issue.


Hi @hickeygamez

The “new version” feature is intended to be use when you have an submission published and, instead to replace a PDF file you would like to keep both PDFs published. Versioning files enables people to consult the first and the latest version of a file. You need to publish both to keep them accessible to the public.
When you create versions for files submission a new menu with link to these versions will show up in the detail article landing page.


Ok that’s what I understood, but I don’t know why the original version is still showing up In Press even though I unpublished it. I have a sample screenshot. It shows that it is unpublished and not assigned to an issue, but it is still showing when I check the In Press issue.

Screen Shot 2021-09-15 at 1.07.50 PM

I think I found a work-around. If I assign both versions to the same issue, it seems to fix my problem. Thanks!