COUNTER Report not displaying report titles

This one is a sandbox OJS on CentOS 7 + PostgreSQL 9.2. Our production instance is on similar architecture but already migrated from psql to Maria, so looking to understand/resolve these issues before moving on to production.

  • Application Version - OJS 3.2.0-3

  • Description of issue

    • Definitely Broken
      The COUNTER Reports page does not show the names of the reports (e.g. Journal Report 1) and instead shows ##plugins.reports.counter.jr1.title##. Selecting the View Report from Tools>Report Generator leads to wsod.

    • Probably by Design
      The year link won’t be generated on the COUNTER Reports page unless one of the articles has been opened in the pdf viewer. The reports generated only include stats on full text pdf (ie MetricType ft_pdf). I may have missed that in the OJS docs, but the project counter docs make it pretty clear that they only want to capture successful full-text request, so this is probably by design. This is a sandbox that has been around since 2016 and there are entries in the metrics table dating back to 2016 through 2020. Those data show up in the Statistics>Articles graph, but not in the COUNTER Reports article and journal reports. The full data also seem to show up when getting the Usage Statistics Report (Tools>Report Generator>Usage Statistics Report), but I only tried that on a single journal.

  • Steps you took leading up to the issue
    Upgraded from 3.1.2-1.

  • What you tried to resolve the issue

    • Removed from the versions table references to usageStats and counter that were old. Tested to make sure that useageEventLogs where getting processed automatically by Acron and processed some manually to see if anything unusual happened. Looked at the counter template to see if there was anything obviously wrong.

    • Installed a clean copy of OJS using MariaDB. This resolves the WSOD error when getting the View Report. But the report titles on the COUNTER page are still broken.

  • Error log messages if applicable
    Nothing in the PHP error log for the COUNTER page where the titles of the reports don’t show up. For the WSOD when I try to run the View Report, I get the following in the error log:

PHP Fatal error:  Uncaught Exception: DB Error: ERROR:  invalid input syntax for integer: 
"STATUS_PUBLISHED" Query: select "s".* from "submissions" as "s" where "s"."context_id" = ? and "s"."status" in (?) group by "s"."submission_id" order by "s"."date_submitted" desc in
 /var/www/ojs32/lib/pkp/classes/db/DAO.inc.php:703
Stack trace:
#0 /var/www/ojs32/lib/pkp/classes/db/DAO.inc.php(103): DAO->handleError(Object(ADODB_postgres8), 'select "s".* fr...')
#1 /var/www/ojs32/lib/pkp/classes/db/DAO.inc.php(201): DAO->retrieve('select "s".* fr...', Array, false)
#2 /var/www/ojs32/lib/pkp/classes/services/PKPSubmissionService.inc.php(103): DAO->retrieveRange('select "s".* fr...', Array, NULL)
#3 /var/www/ojs32/plugins/reports/views/ViewReportPlugin.inc.php(72): PKP\\Services\\PKPSubmissionService->getMany(Array)\n#4 /var/www/ojs32/lib/pkp/pages/management/PKPToolsHandler.inc.php(155): ViewReportPlugin->display(Array, Object(Request))
#5 /var/www/ojs32/lib/pkp/pages/management/PKPToolsHandler.inc.php(58): PKPToolsHandler->report(Array, Obje in /var/www/ojs32/lib/pkp/classes/db/DAO.inc.php on line 703, referer: https://scp.library.illinois.edu/journals/index.php/pri/management/tools

Hi @IOPNdev,

Try applying this change: https://github.com/pkp/ojs/commit/ca5838d80d7c166623f8b2815b5ef2993d811a1b

Please report back whether it helps or not!

Thanks,
Alec Smecher
Public Knowledge Project Team

Thanks @asmecher,

That fixed the View Report. Much appreciated. I’m guessing that the missing titles on the COUNTER Report page is just cosmetic and not connected to any underlying issue.

Best,
Alex

Hi @IOPNdev,

Thanks for confirming!

I also fixed the missing titles in a separate commit yesterday: https://github.com/pkp/ojs/commit/87fbf6c6286bf9baea87e5178f786840d54403c4

Regards,
Alec Smecher
Public Knowledge Project Team

Awesome, thanks @asmecher!

1 Like