Contact tab in proflle empty

The Contact tab in Profile is empty


Screenshot attached.


Hi @PaulS,

I’m wondering if you might try clearing caches: Site Administration (as well as your browser cache) - to see if that makes a difference?

Best regards,

PKP Team

No, it didn’t. I cleared all caches and even used Incognito browser but still the same.

Hi @PaulS,

Hmm… not sure what could be causing this. Are you able to check your PHP error log messages for any relevant error messages there

PKP Team

What should I look for in the PHP error log that would cause the error?

Hi Roger @rcgillis

Please see error log line below;

thrown in /home3/tesollic/public_html/connect/plugins/generic/usageStats/ on line 777


Hi Roger @rcgillis ,

Please see the error below the re-occurs all the time. I guess this is the cause. What needs to be done?

thrown in /home3/tesollic/public_html/connect/lib/pkp/pages/user/ on line 138
[08-Oct-2021 08:29:17 America/Boise] PHP Fatal error: Uncaught Error: Non-static method AccessKeyManager::generateKeyHash() cannot be called statically in /home3/tesollic/public_html/connect/lib/pkp/pages/user/
Stack trace:
#0 /home3/tesollic/public_html/connect/lib/pkp/classes/core/ RegistrationHandler->activateUser(Array, Object(Request))
#1 /home3/tesollic/public_html/connect/lib/pkp/classes/core/ PKPRouter->_authorizeInitializeAndCallRequest(Array, Object(Request), Array, false)
#2 /home3/tesollic/public_html/connect/lib/pkp/classes/core/ PKPPageRouter->route(Object(Request))
#3 /home3/tesollic/public_html/connect/lib/pkp/classes/core/ Dispatcher->dispatch(Object(Request))
#4 /home3/tesollic/public_html/connect/index.php(68): PKPApplication->execute()
#5 {main}

Hi @PaulS,

Thanks for this info. I’ll check with some of our other team members to see if they can help pinpoint what this error might be.

Best regards,

PKP Team

What’s the version of your PHP?

I’m currently PHP 8.0.

Any specific version I need to use?

PHP version 8.0.10. I can downgrade if needed.

Are there any updates to this query?

Please, downgrade to 7.4 and check whether it helps.

Hi @janiosarmento

I followed your suggestion. Took 3 steps.

  1. Downgraded to 7.4
  2. Took a little time
  3. Cleared cache

It worked for a second there but reverted back to empty content again.

A post was split to a new topic: User account validation issue