Configure captcha settings

Hi PKP Team.
I’d like to know the path to the font location in order to configure the font used by the system. I’m trying to use captcha for registration.

I need your help please. Thanks.

Hi @LionnelG,

We do our best to answer all the questions as quick as we can. We’re an small team though, some questions might take a few hours or days to be answered. Just wait a little bit and avoid polluting the forum ok?

To your question: I don’t think you need the font_location setting to make reCaptcha working. See this old thread but that I think it’s useful for the server requirements:


Hi @beghelli,
I saw the thread you suggested.
I tried without modifying the font location. The field for captcha appears but with no letter. I think it’s recommended to point the font_location variable to a font that exists on the system as suggested on this.

Is there another way to make it work???

Are you using a recent version of OJS? Consider using recaptcha instead of captcha. The captcha system is known to be ineffective against modern bots. The recaptcha service is a webservice provided by Google, and doesn’t rely on a local font file.

Hi @ctgraham,

I tryed to turn on recaptcha but nothing hapens no recaptcha on register screen (not apearing)? I got from google the 2 keys and I pasted them there. (OJS 3.0.1)

my config:

; Whether or not to enable ReCaptcha
recaptcha = on
; Public key for reCaptcha (see
recaptcha_public_key = 6LfY9wwUAAAAI.......
; Private key for reCaptcha (see
recaptcha_private_key = 6LfY9wwUAAAA.......

Are the general captcha settings still on as well? All of the settings captcha, captcha_on_register, and recaptcha must be “on” for recaptcha to display on the registration page. Striking that, because it only applies to OJS 2.4.x. I think OJS 3.x should just require the key in