Configuración Comando tar

Hola, alguien me puede colaborar con lo siguiente, resulta que al querer instalar un modulo nuevo recibo esta respuesta el comando tar no esta disponible, como puedo configurarlo estoy utilizando OJS 3.1.1.
image

This is configured near the end of the file config.inc.php:

You will need to enter the file system path to the tar command here. If you do not know what the correct path is, check with your system administrator or your hosting provider.

Gracias si la configuración es la siguiente.

image

You will need to check with your system administrator or ask your hosting provider if the path of /bin/tar will work on your server. You may need to specify another path here.

Tengo el mismo problema

¿Como lo solucionaste?

Gracias

dear @ctgraham @asmecher i install tar for windows and i copy the path to tar = but it didnt work. I am using wamp server but i dont understand how you say to check system administrator if you have a solution let me know please i will attach a screen shot of what i am sayingSin%20t%C3%ADtulo

I think you are almost there. I suspect, though, that the file actually has an extension which may be hidden in your file explorer. You can see it by checking “File name extensions” under the “View” menu in Explorer. Try putting that resulting path in quotes, perhaps:
tar = "C:\Program Files (x86)\GnuWin32\bin\tar.exe"

Alguien pudo solucionarlo finalmente? Cómo encontraron la ruta? Colocan TAR en alguna carpeta específica del servidor? Gracias

Hi @ctgraham,

I try to solve the problem with tar.exe. Cannot install plugins and received an error for tar in config.inc.php (The uploaded plugin archive does not contain a folder that corresponds to the plugin name.),
I find tar.exe and in the config.inc.php and inserted
tar = C:\Windows\System32\tar.exe instead tar = /bin/tar
with quotes and without, but still doesn`t work. I read other post but all back me here.
Something is wrong with configuration in config.inc.php
What will be correct settings for tar in config.inc.php? How to solve this?
I am using Open Journal Systems 3.2.1.2.

Regards,
Lazar

This message suggests that the tar command has been found, but that the plugin archive is not valid. What plugin are you trying to upload, and what was the source?

Hi @ctgraham,

The problem was solved. I answered on the post PLN Plugin doesn`t work - Failed Ajax request or invalid JSON returned - #10 by Lazar_Stosic.

Thanks.
Lazar

@David_Armando_Santac @ctgraham @Fernando_Bernal @amvinasa @astevens @madileweb @marchitelli @Vitaliy @delzimar

Hi…!
I had the same problem in all my Journal with different OJS 3.x versions (3.1.1.4, 3.1.2.1, 3.1.2.0, 3.2.1.2) so I think this solution can be for all 3.x versions.

My server / hosting correctly has the path to the tar application. (tar = / bin / tar).

In error_log I have these messages:

PHP Warning: exec () has been disabled for security reasons in /home/xxxx/public_html/lib/pkp/classes/plugins/PluginHelper.inc.php on line 67
[20-Mar-2021 11:26:23 UTC] PHP Fatal error: Uncaught Error: Call to a member function getProductType () on string in /home/xxxx/public_html/lib/pkp/classes/plugins/PluginHelper.inc. php: 113
Stack trace:… (The error message has more details but I think these lines are the most important).

Different messages appear in the Journal depending on the OJS version installed, examples:

For Journal with OJS 3.1.2.0 the error message is:
The uploaded plugin archive does not contain a folder that corresponds to the plugin name.
pkp forum 2

For Journal with OJS 3.2.1.2 the error message is:
“The” exec “PHP function has been disabled on your server. Contact your system adminstrator to enable it.”
pkp forum1

Solution:
I was able to find some good advice here: php - Warning: `exec()` has been disabled for security reasons - Stack Overflow

If you have access to your server you must enable (from WHM) PHP-FPM and “exec” php function.

If you do not have access to your server you should ask your service provider to enable:
1.- PHP-FPM
2.- “exec” php function for your hosting.

After this everything works normal.

1 Like