Change suffix crossref

Hello, I have a suffix already created to upload articles and numbers DOI to CrossRef. But my question is where can access to change the suffix and put a new one for ojs magazine. Thank you.

The DOI is configured in:
User Home → Journal Mananger → System Plugins → Public Identifier Plugins → DOI → Settings.

If you are changing your DOI config from something you were testing earlier and now want to put into production, you will want to “Reassign DOIs” from that page as well.

Could you give me an example? I see this and I’m lost. Barataria want to put as suffix.

What do you want the suffix to look like?

Hello , I indicated that change would want ( next to the link ) .

Example: DOI:

I want to change the end of rbcs by the barataria .

This looks like a DOI for a whole issue. If so, you would enter:
para números: “rbcs.v%vi%i”

I do not understand I just want to change the text portion “rbcs”

There are three options to generate DOI suffixes.

In the first option, you choose a pattern.
In the second option, you use a system pattern.
In the third option, you add a DOI manually to every item.

In the first option, you can enter any text you want, and the characters like “%j”, “%v”, “%i” will be replaced with OJS identifiers. All of the other text you enter will be unchanged.

The system predefined model will look like “10.20932/rb.v0i20”. This is the [prefix]/[%journal].v[%volume]i[%issue]

If you want every DOI to include rbcs, enter:

Solved my issue . Add a note . It must give the assign button again to apply all changes , if you want this new suffix applies to all already created (as was my case ) .

Thank you again for all your help.

Hi @ctgraham , I just received response CrossRef after climbing the xml. And I suggest that after the adjustment% are introduced into the urls for DOI. I should perform?


What did you enter for “para números”?

Journal number.

The same applies to article.

On the DOI settings page, what text did you enter in the box with the label “para números”?

Yes, I’ve entered everything as I indicastes in the catch.

In para números, the entry ends in a “%”. You probably want it to end in “%i” so that “%i” is replaced by the Issue identifier.

Indeed, the mistake was mine. Apology and already this all sorted out and working properly.