Cannot schedule for publication, "You don't currently have access to that stage of the workflow."

Hello, UPDATING this post with an exciting fix!
I have read previous posts on this but none of the fixes in those threads help. I am supposed to publish our issue tomorrow (ideally), and I have published issues with no problem for seven years, but today I am told “You don’t currently have access to that stage of the workflow” when I try to “Schedule for Publication.” I am a user with all the appropriate roles, I do not have “this user can only [etc]” checked, I made sure to click “permissions” on section editor in Workflow. There is no obvious reason that I cannot schedule my articles for publication. I just can’t. Advice welcome!

UPDate: FIXED! See below!

Steps I took leading up to the issue: The usual publication steps.

What I tried to resolve the issue: Double-checked that I have roles including Journal Manager, Journal Editor, Section Editor, Production Editor, etc. I double-checked that all these roles are permitted to alter metadata and that none of them have the “only… otherwise authorize” setting checked. I double-checked that on each submission, in Workflow, I clicked on Edit under my name and Section Editor and ensured “permissions” is checked and the “only” thing is unchecked.

Application Version - e.g., OJS 3.1.2: 3.3.0.6

Additional information, such as screenshots and error log messages if applicable: The Fix, my fellow strugglers, was this: On the page for the submission I wanted to schedule, I see myself as “Section Editor,” right? But if you click Assign, you can also add yourself as “Production Editor” (assuming that in Users and Roles you already have this assigned to you). I assigned myself as “Production Editor” as well, then tried Scheduling again – Success! This is new, and I’ve never had to do this before. So it’s just clunkier than it’s ever been but at least I can publish now, that is, once I go through every submission for this issue and add myself, sigh. But hey, a fix!

Hi @fpqonojs

I will just add your comment on a separate post to set it as solution for future users that might need it.

Additional information, such as screenshots and error log messages if applicable: The Fix, my fellow strugglers, was this: On the page for the submission I wanted to schedule, I see myself as “Section Editor,” right? But if you click Assign, you can also add yourself as “Production Editor” (assuming that in Users and Roles you already have this assigned to you). I assigned myself as “Production Editor” as well, then tried Scheduling again – Success! This is new, and I’ve never had to do this before. So it’s just clunkier than it’s ever been but at least I can publish now, that is, once I go through every submission for this issue and add myself, sigh. But hey, a fix!

Best,
Israel Cefrin
PKP Team

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.