Cannot install and HTTP ERROR 500

Hi, i just downloaded OJS version 3.0.2 but when I tried to install it, it fail. The message is HTTP ERROR 500. When i check the error log, it’s written

[Wed Apr 12 20:31:00.393348 2017] [php7:error] [pid 2308:tid 1640] [client ::1:53550] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\xampp\htdocs\jurnalku\lib\pkp\lib\adodb\drivers\\nStack trace:\n#0 C:\xampp\htdocs\jurnalku\lib\pkp\lib\adodb\ ADODB_mysql->_connect(‘localhost’, ‘root’, ‘’, ‘jurnalku’)\n#1 C:\xampp\htdocs\jurnalku\lib\pkp\classes\db\ ADOConnection->Connect(‘localhost’, ‘root’, ‘’, ‘jurnalku’, false)\n#2 C:\xampp\htdocs\jurnalku\lib\pkp\classes\db\ DBConnection->connect()\n#3 C:\xampp\htdocs\jurnalku\lib\pkp\classes\db\ DBConnection->initConn()\n#4 C:\xampp\htdocs\jurnalku\lib\pkp\classes\db\ DBConnection->initCustomDBConnection(‘mysql’, ‘localhost’, ‘root’, ‘’, ‘jurnalku’, false, ‘utf8’)\n#5 C:\xampp\htdocs\jurnalku\lib\pkp\classes\install\ DBConnection->__construct(‘mysql’, ‘localhost’, ‘root’, ‘’, ‘jurnalku’, false, ‘utf8’)\n#6 C:\xampp\htdocs\jurnalku\lib\pkp\classes\install\ P in C:\xampp\htdocs\jurnalku\lib\pkp\lib\adodb\drivers\ on line 456, referer: http://localhost/jurnalku/index.php/index/install

Whats should I do? Thanks.

1 Like

This indicates that you do not have the PHP mysql library installed or enabled for your server. You may find that you have the mysqli or postgres library installed instead. If that is the case, you can change the database driver option in the installation form. Otherwise, you may need to install the mysql library.

Hai, thanks for your quick response. Should I change the database driver when I fill the installation form? I put the folder name that I used in xampp to put ojs (in this case jurnalku). What should I change into?


The database driver is selected on the installation form.

If there are brackets around the driver name, your system probably doesn’t have support for that driver installed.

Thanks, I have solved this problem. But eventually another problem come
out, I cannot access the setting wizard after create journal. It say,
localhost says: the current role does not have access to this operation.

I’m trying to find error log, but I cannot find anything, in apache error
log or phone error log.

Can you give me help me this problem? Thank you.

You’ve also posted this question here:

That is the better place to follow up, since the question diverges from the original problem.