Cannot enable new lournals

Hi,
After upgrading to OJS 3.2, we are unable to enable new journals that have selected English as their primary locale to appear publicly on the site. Our journal platform, which contains many different journals, has Danish as its primary locale. See: https://tidsskrift.dk/

enable

Best
Niels Erik

Hi @nef,

This sounds odd. So, when you try to enable it is it indicating any particular setting as creating the error? And, the journal just simply not appearing among the list of journals? I do see an English journal here, for example: https://www.conjunctions-tjcp.com/ - but I don’t know enough about your instance to know whether or not this is one of the affected journals.

-Roger
PKP Team

Dear @nef
Like most users, it seems that you use mod_rewrite rules to remove index.php and journal path.
and there are double slashes in the link that @rcgillis added.

https://www.conjunctions-tjcp.com//announcement

So, you need to check your mod_rewrite rules (in .htaccess)
Perhaps, those posts might help you to identify the problem.
Regards,

Update: When I visit the journal that exist in the screenshot, it has published its first issue on 21th of May. Perhaps, you might have tried to use an existing journal path?

https://tidsskrift.dk/irtp/article/view/127093

Thank you very much for the new in-depth answers. We will look into this as soon as possible. Initially, we solved the problem as follows:

The problem occurs because the field “Journal initials” (which is a required field) wasn’t filled out in our site’s primary locale (Danish) but because the Danish wasn’t activated on the journal we couldn’t enable the journal to appear publicly on the site. It was really difficult to figure out, what caused the problem.

enable-a

We had to choose Danish under ‘Language’, both under UI and Forms

enable1

After completing the ‘Journal Initials’ field (see below), the journal was successfully published. We must therefore conclude that the information under ‘Journal Identity’ must be entered in both English and Danish.

enable2

After enabling the journal to appear publicly on the site we could turn off Danish UI/Forms again.

1 Like

This topic was automatically closed after 13 days. New replies are no longer allowed.