Can not install locale language on OJS

i am using ojs a few weeks ago, ojs was no problem. but a few days ago, in the Administration> Site Setup> Languages setting, Locale was marked with an asterisk (*), whereas previously it appeared English and Indonesian.


Then when I tried to click Install locale, an error message appeared:
Downloading language packs from the Public Knowledge Project web server is not currently available because:
Your server does not have or allow execution of the GNU “tar” utility.
OJS is unable to modify the locale registry file, typically “registry / locales.xml”.
Language packs can be manually downloaded from the PKP web site.


I have installed tar on my ubuntu and previously there was no error like this. Is this because of the permissions of the file or directory? or is there a missing configuration?

My apache error.log :
[Fri Dec 18 20:12:01.803676 2020] [php7:warn] [pid 110893] [client] PHP Warning: filemtime(): stat failed for registry/locales.xml in /data/www/ojs322/lib/pkp/classes/i18n/ on line 701
[Fri Dec 18 20:12:01.806623 2020] [php7:notice] [pid 110893] [client] PHP Notice: Undefined index: id_ID in /data/www/ojs322/lib/pkp/classes/site/ on line 39
[Fri Dec 18 20:12:01.806635 2020] [php7:notice] [pid 110893] [client] PHP Notice: Undefined index: en_US in /data/www/ojs322/lib/pkp/classes/site/ on line 39

Please help with this problem


I have the same problem,
I have upgraded a journal from 3.0 to and the “install locale” open the popup but without any content.
On the same server I have other OJS that works perfectly, also migrated by version 2.4.x.
All OJS applications installed have the same priviledge.
Also I checked for the registry/locales.xml and it exists.
But I don’t understand how to solve.


When you upgrade, are you also copy cache folder? And are you install your ojs in different folder (other than /var/www) ?


Yes I copied everything and in a different folder,
in any case I did the same for an another ojs installation and worked without problem,
and the install locale carries the languages


I also do that, and after I change the root directory to /var/www and I do clean the cache on administrator dashboard, the error gone and it work until now. I think it because the permission, but I still do not know where permission that make it error. And change the web root directory to /var/www solve this problem.