Call to a member function getCurrent() ... lib/pkp/classes/site/ on line 145

I am getting the following error just after clicking on “Intall Open Journal System” in OJS 2.4.8:

Fatal error: Call to a member function getCurrent() on a non-object in /home/journali/public_html/lib/pkp/classes/site/ on line 145

Server info:
OS: Linux
PHP Version: 5.4.45
Apache Version: N/A
DB Driver: mysql
DB server version: 5.5.45-cll-lve

And if I try to open journal website again then I get the following error message:

Fatal error: Call to a member function getVersionString() on a non-object in /home/journali/public_html/lib/pkp/classes/template/ on line 196

I have tried three time and get the same message. I try my best to figure out but fail. Therefore someones help is needed. I shall be very thankful.

If you are upgrading the system, I advise you to download the upgrade patch because I had problems installing the 2.4.8 version and then I got appeared other more serious errors. I downloaded the patch for the version used and the command line ran the patch.

Thanks for your reply. I was installing fresh version 2.4.8. I will see, is 2.4.7 work for me?

Hi @atiq4pk and @prdr30 ,

Generally we recommend the full-package upgrade rather than the patch upgrade. I don’t think @atiq4pk is having the same problem as you, @prdr30, because I think @atiq4pk s trying to install a fresh copy of OJS and you were upgrading from a previous release.

@atiq4pk, can you confirm whether you’re able to install OJS 2.4.7-1?

@prdr30, can you describe the upgrade problem you were encountering in more detail?

Alec Smecher
Public Knowledge Project Team

Hi Asmecher,

I had these two options, the use of full-package upgrade, first introduced error updating as the DOI record, with this error resolved, many records were no longer shown on the site, most of the site was with strange characters. Now the patch upgrade was everything quiet and fast, able to migrate, test and put in the air in one day. I just thought strange and bad take the view counter that was in version 2.3.8, which could create a patch to enable this function. Sorry I had to do the migration from version 2.3.8 to 2.4.8 version.
Sorry for my English.


Hi @asmecher

I have installed OJS 2.4.7-1 and it is working fine.

When I have uploaded the latest version OJS 2.4.8, I uploaded the files by ftp client after uncompression but in this case (for version OJS 2.4.7-1), first I uploaded the file then uncompressed it there. This is the reason I am not certain that only reason is new version. If I get some time, I will try with version 2.4.8 the same.


I have tried with OJS 2.4.8 by first uploading the whole compress file on the server, then uncompressed it there. Installation was successful… :slight_smile: It mean problem arise when I was uploading files one by one by ftp. I uploaded all the files by ftp client but I noticed that it is very difficult to figure out that all the files are uploaded properly. Some time it left few bytes of file size. It may cause the problem.

I am very thankful to PKP for such a beautiful software and their support.

PS: I am not expert and I was thinking that installation of OJS is beyond my scope. But thanks to this forum/people who help me to think in a way that I was succeeded.

Hi @atiq4pk,

Glad to hear you got it working! Thanks for the kind words.

Alec Smecher
Public Knowledge Project Team