Bug order back issues? (OJS)

I use OJS. I’m having trouble saving a back issues order. In particular, I click “done” but it doesn’t save the order. “Done” does nothing. It has worked for months and suddenly it has stopped working.

Are there any bug reported about it? What can happen?

Thank you.



Hi @InfoDocu

That’s a really old version of OJS 3, so my first suggestion is an upgrade to see if that resolves the problem. There was a bug related to custom ordering in an issue’s table of contents, filed here:

But that sounds different.


1 Like

Hi @jnugent

Thanks for your quick response.

I will wait a few days before updating. It is a delicate process and I would prefer not to do it.

The point is that it worked yesterday and not today. I want to locate the origin. Is there a file that records these errors? I don’t think so because OJS doesn’t actually show any error messages, it just doesn’t work.

In over 8 years using OJS I have never seen anything like it.

Hi @InfoDocu

This sounds like this bug here:

Which was ultimately fixed in 3.2.1, perhaps 3.2.1-2. The bug I linked to previously would not save a new order if you had already ordered it but that bug was for tables of content.


Hi @jnugent

Thank you for showing me similar cases.

For now I have not been able to solve it but I have discovered the specific situation in which it happens.

This is when I publish a new issue and it is moved from “future issues” to “back issues”. If I don’t add a new issues in “back issues” the “back issues” list I can order it and save it.

On the other hand, is there no chance of knowing that it is failing? It’s weird that I’ve been working for a year and suddenly not anymore.

I will be writing in this post if I have news in case someone is helpful. I hope I don’t have to update but it is very likely


Hello again,

I have continued researching this bug. I have located in the file “apache.error.log” the line where I think the error appears. Would it provide any clues?

On the other hand, is it possible to solve it by changing any line of a file? Hi, @asmecher I saw that you provided this solution for a similar case.

Do you know what could be done in this case? Or upgrade to 3.3.0-8?

Thank you very much for your time.

Hello everybody

I found the solution to this situation and it might be the same for tables of contents.

It was a firewall that was blocking the request to save changes because it was detected as suspicious.

I hope it helps other people and saves them time.