Bootstrap Theme

Sorry if this question was already asked before.
Anyhow, after applying bootstrap theme, I think the links for the CSS files are incorrectly merged:$$$call$$$/page/page/css?name=bootstrap

Am I missing something?
Thank you in avance. OJS 3 is great!



I get a similar error:

404 Not Found, referer:$$$call$$$/page/page/css


Hello Andrés
Any luck with this issue?

Hi all,

That blank page probably corresponds to an error in your PHP error log. Can you check there to see if there’s something useful?

Alec Smecher
Public Knowledge Project Team


Only a warning:

PHP Warning: Cannot use a scalar value as an array in /var/www/test-ojs/lib/pkp/classes/core/ on line 133

This warning is repeated frequently in the log.


Hi! I would like to thank @NateWr for his contribution. Even the default 15 themes are already looking great!

The only issue I can see is that the PDF Viewer window takes only a half part of the screen, another lower part remains blank. Is it only my problem, or someone else can reproduce it?


1 Like

@Ph_We, Same problem on our side too.
Plus, logos are too small and something looks awkward.

Switched back to default theme.

1 Like

@anupent, thanks.
Yes, the logo should be long enough to be visible at all))

Good day,

Ready bootstrap themes dont support all functions of default theme. For example search window does not expand after clicking on it. Or article view page on bootstrap loose it right article block (how to site info, section etc) which goes to the page bottom. There some new text is showing in make a submission page on bootstrap which I cannot modify or translate to another language. There is only several options for changing colors in exampled bootstrap themes (dont now why is so). I have tried to change them in bootstrap .less files but worked only 3 or 4 from many css colors. And so on :slight_smile:

Hi everyone,

The Bootstrap3 theme is a community effort to provide a base theme for rapid customization. It implements an OJS journal using core bootstrap themes but avoids stepping beyond the core components wherever possible.

This makes it easier to drop in different third-party styles, like those bundled with the theme. But in most cases you will need to do a little bit more work with a child theme to really make it shine.

This issue has been filed and you can follow the progress here.

This is just part of the design of Bootstrap 3’s header component. I responded to a similar request with more detail here.

  1. Search uses Bootstrap’s search UI component. The expanding search is just a feature of the default theme and not necessarily a feature of OJS itself (other themes likely won’t use it).

  2. The Bootstrap3 theme just uses a different layout. But all the same content should appear. If there’s any missing content, let us know.

  3. Can you provide more information abotu the text you’re unable to translate in the Bootstrap3 theme?

  4. I’m not sure what you’re saying about “changing colors” near the end of your comment. Could you describe the problem you’re having in more detail?

Artice page with bootstrap goes like one big and long block. In the original theme article page consists of 2 side by side blocks. Content is the same. If I could somehow bypass this problem it would be great. If there is a need of additional info I could provide it.

Attached additional screen of the text which appears only in bootstrap theme. It appears at the bottom of the “make a submission” page

Edit button throws me on the journal “Masthead” page where I don`t see this text at all.

As for changing colors I have tried to change color of “.alert-info” block (one of the standard bootstrap classes as I understand it) in variables.less file of my chosen bootstrap theme. Worked only this colors: #d9edf7 #5bc0de #3399F3 #3498DB. Changing to others had no effect on the appearance.

@Vitaliy thanks for the additional info. I’ve filed a bug report for the Privacy Statement text on the bootstrap3 repository.

The color issue describes sounds like something else is happening. Maybe the colors you’re trying out aren’t valid color definitions, or you’re running into some other issue. Can you show some code you’re using that isn’t working?


Example of code:

`@brand-info: #d9edf7; //#5bc0de #3399F3 #3498DB

I have commented out the colors I am not using. Don`t remember exactly if I commented colors that work to not forget them or vice versa
Only several colors work from all of the spectrum.