Authors missing option to upload a manuscirpt to an existing submission record

When authors login to add a revised manuscript to their submission record, there is no option for them to “upload file.” See the screen capture attached. 34%20PM

Hi @tpearson,

As far as I know that is not possible. The author can either:

  • add a new file and in discussion mention to editors to use the new document instead, or
  • replace the document in the next phase, the review if asked for

Regards, Primož

Thank you for your helpful response. It sounds like you’re implying that if a submission has been sent to Review, and then authors have been asked to revise and resubmit, that they should be able to access the Review tab? Maybe THIS is where the problem lies for us. When I “login as” the author, the submission tries to open in Review, but produces an error message (which is difficult to exit out of). See screen shot attached.

I wonder why it is not possible for an author to upload a revision BEFORE it is sent to review. I think that it is fairly common for an author to intend to change something and only remember after the initial upload. As long as the article hasn’t been moved to the Review stage, there should be no restriction of re-uploads. although that is not included in the current OJS functionality.

I, as editor, often need to contact the author of a recent submission since there are issues that need to be resolved before I would want a reviewer to look at it, for example using a style with section numbers when we do not employ them.

This would seem to be an easy function to implement? What do you think?

I hadn’t realized that this functionality wasn’t available. I agree with you that it seems like a natural course of action by authors. We haven’t run into that problem yet.

hi @tpearson, I have the same problem and i am using the OJS 3.1.1-4.
If you have solved the problem, please help me out.
I have no idea how to resolve this issue also not aware wheteher this is a bug in OJS 3.1.1-4 or could have caused from other settings in OJS.

Hi Suresh,
Sorry it’s taken me so long to get back to you. I’m just emerging from the crush to get the next issue out.
The good news is that I think I solved the problem (at least the problem WE were having, I don’t know if this will work for you too). I discovered that I had mistakenly limited the “role” defined for the author, so they didn’t have access to the review tab of the admin tool. See the screen capture attached. Once I checked that box to give the author access to review, Authors have had no problems logging in and submitting a revised manuscript after we’ve asked for revisions. image001
I hope this works for you too. I’m using OJS