Articles not getting listed in OAI

Hi everyone!

Applciation version: OJS 3.1.2

I need to get my journal indexed by nelti ( which requires that the OAI-PMH metadata service is working correctly

I have enabled OAI for one my journals at: but the page does not list any of the articles. The actual articles are all listed on the website:

Also nelti informed me that the they are not able to scrap any articles at all. I have already enabled the option “Enable OAI access to content”

Any help would be appreciated!

Hi @sushantv

Looking at the OAI page for your journal, I see your articles listed in the metadata response. Did you get this problem solved, then?


Thanks for your response Jason. Yes, all of my journals OAI is now working, except for one which just shows a blank page:

Also when I tried to validate it, it shows a lot of errors.


Would you have any idea why is it happening only for this particular journal? Thank you

Hi @sushantv

Looking at the source for the page that’s broken, it appears as though there is a invalid character. If you search for, say “niacin increased” you’ll find it; there’s an unparsable character between 400 and µM.

The OAI XML output can be quite strict about being valid UTF-8. I’d encourage you to look at that particular article and see if you can clean up the metadata for it.