ARK and PURL Problem

I am experiencing an issue with the ARK and PURL plugins in the latest version of Open Journal Systems. Whenever I attempt to access the settings for these plugins, I encounter an error stating, “Failed Ajax request or invalid JSON returned.” This error prevents me from making any configuration changes to the plugins. Could someone please help me identify and resolve this issue? Here is a screenshot of the error for more context.

OJS 3.3.0.5

Hi @SNR_ELC,

Can you elaborate how you installed the plugins? Was it through the plugin gallery, or some other means?

-Roger
PKP Team

This plugin isn’t available in Plugin Gallery so I downloaded it from the PKP forum and installed in the OJS.

Hi @SNR_ELC,

Plugins are not available for download via the plugin forum - do you mean Github perhaps? It is not recommended to install plugins directly, other than from the plugin gallery, if possible, because they may be incompatible with your version of OJS. There is a version for 3.3 for the ARK plugin here: Releases · yasielpv/pkp-ark-pubid · GitHub . Similarly, there is a release for 3.3 for the PURL plugin here: Releases · yasielpv/pkp-purl-pubid · GitHub.

You may want to try installing them manually, via the correct github download. Not having used these plugins, I can’t personally vouch for them, but again, i would suggest that you exercise caution when installing them, or any plugin not in the plugin gallery.

-Roger
PKP Team

Thanks for the quick response, dear. I’m already using the same plugins you shared, but facing the problem I mentioned. Moreover, I’m using the latest version of OJS.

Hi @SNR_ELC,

If you are using the latest version of OJS, they are unlikely to work as they have not been tested against the latest version.

-Roger
PKP Team