Archiving page on OJS 3.1.2.0 and LOCKSS questions

Hi,
we would pass from 2.4.8 to 3.1.2.0 OJS but, after update in test server, I get some errors.

The archiving page (fundamental for us because we need LOCKSS) has a strange behavior: I can’t disable “PKP PN plugin enabled” option, if I try, I get a confirmation of changes saved but keep to be checked.
When I open the Archiving page I see a static “Loading” text under setting link.

The browser console shows the following error:

VM1949:1 GET http://WEB-ADDRESS/$$$call$$$/plugins/generic/pln/controllers/grid/p-l-n-status-grid/fetch-grid?_=1555059468086 404 (Not Found)

In server error logs I get:

AH01071: Got error ‘PHP message: PHP Warning: Declaration of OpenAIREDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 19PHP message: PHP Warning: Declaration of DRIVERDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/driver/DRIVERDAO.inc.php on line 0’, referer: http://WEB-ADDRESS/index.php/FE/submissions

AH01071: Got error ‘PHP message: PHP Warning: Declaration of OpenAIREDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 19PHP message: PHP Warning: Declaration of DRIVERDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/driver/DRIVERDAO.inc.php on line 0’, referer: http://WEB-ADDRESS/index.php/FE/management/settings/website

AH01071: Got error ‘PHP message: PHP Warning: Declaration of OpenAIREDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 19PHP message: PHP Warning: Declaration of DRIVERDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/driver/DRIVERDAO.inc.php on line 0’, referer: http://WEB-ADDRESS/index.php/FE/management/settings/website

AH01071: Got error ‘PHP message: PHP Warning: Declaration of OpenAIREDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 19PHP message: PHP Warning: Declaration of DRIVERDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/driver/DRIVERDAO.inc.php on line 0’, referer: http://WEB-ADDRESS/index.php/FE/management/settings/website

AH01071: Got error ‘PHP message: PHP Warning: Declaration of OpenAIREDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 19PHP message: PHP Warning: Declaration of DRIVERDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/driver/DRIVERDAO.inc.php on line 0’, referer: http://WEB-ADDRESS/index.php/FE/management/settings/website

AH01071: Got error ‘PHP message: PHP Warning: Declaration of OpenAIREDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 19PHP message: PHP Warning: Declaration of DRIVERDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/driver/DRIVERDAO.inc.php on line 0’, referer: http://WEB-ADDRESS/index.php/FE/management/settings/website

AH01071: Got error ‘PHP message: PHP Warning: Declaration of OpenAIREDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 19PHP message: PHP Warning: Declaration of DRIVERDAO::setOAI(&$oai) should be compatible with PKPOAIDAO::setOAI($oai) in /SERVER-WEB-FOLDER/plugins/generic/driver/DRIVERDAO.inc.php on line 0’, referer: http://WEB-ADDRESS/index.php/FE/management/settings/website

Apart from this problem, I’m asking if in 3.1.2.0 there is a PKP PLN Plugin setting page, as for OJS 2.4.8, and how can I be sure that it’s correctly archiving my issues (I can’t find a list of corrected archived issues).

Thank you

Hi @Enzo,

The PKP PLN plugin for OJS 3.x has not been released yet. We hope to get it finished very soon.

The error log entries you quote only contain warning messages; look for Error in the log to see if there’s something relevant further up.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi, I follow the forum since many months waiting news about PKP PLN plugin for OJS 3.x (for us fundamental to pass to 3.x) so I has been surprised noticing in a 3.1.2 test installation the following page


This make me think the plugin was already active in that version.

Anyway, if I open the page I get just the above quoted errors between Apache error logs. I don’t know if it’s OK to get in browser console this error:

VM258:1 GET http://WEB-ADDRESS/$$$call$$$/plugins/generic/pln/controllers/grid/p-l-n-status-grid/fetch-grid?_=1555314930919 404 (Not Found)

And I wonder if it’s OK the static “Loading” text.

If I click on “Setting” button I get this error:


with this server error log:

GET /index.php/FE/$$$call$$$/plugins/generic/pln/controllers/grid/p-l-n-status-grid/fetch-grid?_=1555322350345 HTTP/1.0

Thank you for your reply. Bye

Hi @Enzo ,

I have the same problem in OJS 3.1.2.0, but I have not been able to resolve the error with plugin PKP PLN. You could solve it, and if that’s how you did it