Access denied when installing OJS 3.2

Application Version

Description of issue

I keep getting this weird error where i get a “Access denied” message on a blank screen when trying to install from either the version from the OJS Download Center or trying directly from github Github repo.
If I try to install through the CLI it works, but I’ll still get the same error later on besides stylesheets and other resources not loading either.

I imagine this has something to do with htaccess/permissions/routing but no idea what exactly.
I’ve searched deeply between forums and issues and don’t find the same issue posted already.


  • I’ve downloaded the and placed it in ~/ojs

  • Downloaded and placed it in ~/ojs/lib/pkp

  • composer install on ~/ojs/lib/pkp

  • Added htaccess:

    RewriteEngine on
    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_URI} !-d
    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_URI} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php/$1 [QSA,L]

  • Enabled restful_urls

With either restul urls on or off (and htaccess removed) I get the same error on either https://ojs.test/index/install or https://ojs.test/index.php/index/install

Access denied

I’ve tried to activate error log’s but besides warnings that are already reported (Deprecated call […] pkp/classes/template/ on line 971) no important messages.


Error log messages if applicable
Access denied

Hi @nmorales,

I don’t recommend downloading the .zip files from GitHub – you’ll need to worry about more submodules than just pkp-lib. Instead, get the release package from (or if you want to use the git stable branch, use a git client).

The Access denied message is coming from your web server, not OJS – it’s likely a file permission or virtual hosting (directory) configuration problem. If you put a test PHP script in the same directory you’d likely have the same problem, I think.

Alec Smecher
Public Knowledge Project Team

Hi Alec, thanks for your time.

Indeed the download from worked correctly.
I imagine something i wasn’t doing correctly from the Github Repo but again, didn’t work either from the download at:

I guess that site’s download link should link back to download, or be just a proxy and not offer a different tar/zip file than officially…

Anyways, thanks for your help!

Have a great week.

Hi @nmorales,

The official OJS website is; the other website is not affiliated at all with PKP (who maintains/releases OJS) and may not provide reliable downloads.

Alec Smecher
Public Knowledge Project Team