Upgrade from OJS 2.2.4 to 2.4.8 Error


I do not see where to do this. Is it part of Setup for the Journal manager?

We tried to upgrade to 3.1.0-1 and received the error below.

DB Error: Data too long for column ‘contents’ at row 1

So, I changed the type of contents row of the table notes from text to longtext, but it didn’t help.

Another question

Should we be upgrading to 3.1.1 rather than 3.1.0-1

Hi @RickMath,

OJS 3.1.1 hasn’t been released yet – the latest is currently OJS 3.1.0-1. (Are you seeing OJS 3.1.1 available somewhere? It might be a typo.)

The only place I could think of a contents column being a problem is in the notes table. I suspect you have some problem content there, perhaps a spam submission or something, as the TEXT column should already be big enough to hold it. But to migrate that content using a LONGTEXT, edit lib/pkp/xml/schema/notes.xml, find the definition of the contents column:

<field name="contents" type="X"/>

…and change the type from X to XL. Then restore your 2.4.8 database and re-run the upgrade.

I would suggest checking what the long content is there after performing the upgrade to see if it’s some kind of exotic spam or something.

Alec Smecher
Public Knowledge Project Team


I checked the notes table and there are no records.

Also I do not see where to make the changes mentioned a few posts ago on the email_templates_default_data table

We will try the change to the contents field and get back.

I thought I saw a post on 3.3.1 Must have been a typo.

We tried again and received this

[code: Installer Installer::moveReviewerFiles]
There are no readable files in this directory tree. Are safe mode or open_basedir active?

Hi @RickMath,

There are a few other threads with suggestions for this message; see e.g. this one. It’s likely that you’re encountering yet another data error in your old 2.x install.

Alec Smecher
Public Knowledge Project Team

We found three articleIDs that did not have sections, they were null. We corrected this with section numbers.

The installation of 3.1.0-1 was partially completed. We can get to the site administration page with http://www.jamt-online.org/OJS/index.php/ and log in with the administrator account. When we use http:/jamt-online.org/OJS/index.php/JAMT/ we get a 404 error. The JAMT path is in the admin page as it was before.

The stack trace is
Stack trace at http://www.jamt-online.org/OJS/index.php/JAMT/ is currently showing following :

File: /home/jamtorg/public_html/OJS/lib/pkp/classes/core/PKPPageRouter.inc.php line 197
Function: Dispatcher->handle404()

File: /home/jamtorg/public_html/OJS/lib/pkp/classes/core/Dispatcher.inc.php line 134
Function: PKPPageRouter->route(Object(Request))

File: /home/jamtorg/public_html/OJS/lib/pkp/classes/core/PKPApplication.inc.php line 243
Function: Dispatcher->dispatch(Object(Request))

File: /home/jamtorg/public_html/OJS/index.php line 68
Function: PKPApplication->execute()

I am not sure what to do at this point. I can see users, roles and the other system information on the admin page so all of that is OK.



I enabled the journal to appear publicly on the edit page. When I did the journal was visible and I could see issues and the current issue.

There is no login area or anything else.

When I close the page and tried to open the admin link all I could get was the journal page. I went to the journal table and enabled was set to 1. I set it to 0 and was able to get back to the admin page.

Is this related to the stack trace notices that appear in my last post?

Thanks we are making progress.

Hi @RickMath,

Are you sure the upgrade completed successfully? If it did, you should have received a confirmation message saying so. If the processess stopped with an error, or stopped without confirming that it had completed, your journal might not be fully upgraded and some data errors can result.

The 404 error is explained by the journal being disabled.

When your journal is enabled, and you only have a single journal, the administration tools are mostly folded into Journal Setup, so you likely won’t see them in a separate Administration area. This was done because many of our users only work with a single journal, so the separation of Administration (site-wide) from Setup (journal-specific) was confusing.

The missing login areas etc. might be explained by an incomplete upgrade, but I’d also suggest checking your PHP error log to see if there are any useful details there.

Alec Smecher
Public Knowledge Project Team


I looked at the error log under our public_html follder. We had a front end to www.jamt-online.org that was written by our site admin. www.jamt_online.org/OJS I think pointed to the OJS system. The error log is very long and contains references to php and other files in that front end that is outside of the OJS folder.

I wonder if this is causing the problem with the upgrade failure. I thought about being able to get to the site admin page. If we remove all the frontend files and folders above the OJS folder will we have a problem?

I hope this makes sense.

Thanks for you patience.


I also have the error log in the OJS folder. Can I send it to you?

Hi @RickMath,

Before working with the log, the most important thing to do is to confirm that you receive a message stating that an upgrade was successful at the end of the upgrade process. Without that, there will be a lot of speculation involved.

Once that’s established, then look at the log file. As soon as you view a page that triggers an error message, the entries will be added to the end of the log, so the last entries will be most relevant (and be sure to check the log soon after requesting the OJS page that shows a problem). Look for a message that contains “Error” instead of e.g. “Warning” or “Notice”.

Alec Smecher
Public Knowledge Project Team

The last;upgrade failed. The error log in the OJS folder was from the upgrade. We have gone back to 2.4.8 so I cannot try to see the above. I do have a log from the last failed upgrade. 2.4.8 is working absolutely fine.

There are many references to the install php files. Many in the beginning are like this

Invalid argument supplied for foreach() in /home/jamtorg/public_html/OJS/classes/install/Upgrade.inc.php on line 2087


Only variables should be passed by reference in /home/jamtorg/public_html/OJS/lib/pkp/lib/adodb/adodb-xmlschema.inc.php on line 267

Are we looking in the right place to identify the failed upgrade reasons.

Confused at best but greatly appreciate your help on this.

OK we tried again and got a log that indicated a successful install. I can open the site administrator pages. But when I add the journal path I get a 404 error. I have the log from right after the attempt. Here are the lines right after the attempt.

[14-Dec-2017 20:07:43 America/New_York] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/jamtorg/public_html/OJS3/lib/pkp/classes/core/Dispatcher.inc.php on line 245
[14-Dec-2017 20:07:43 America/New_York] ojs2: 404 Not Found

Hi @RickMath,

Did the message indicate a successfull install or upgrade? What was the message specifically?

Make sure your journal is enabled as you did above to get rid of the 404 message.

Alec Smecher
Public Knowledge Project Team

Here is the end of the upgrade log if that is what you need to see.

The site admin page is working but when I enable the journal there are no menus on the left and nothing in the upper right corner. Still getting a 404 error when I include the path in the url. The path is correct according to the site admin pages. What else do you need to know? I can send the entire upgrade log as an attachment. It is in a 15 page word document.

#2972: Untranslated locale keys in Roles select menu
#2980: order by user_group_id in UserGroupDAO::getByRoleId
#2989: Correct missing table alias for PostgreSQL upgrade
#2996: Paypal plugin has undeclared dependency
#2998: [OJS] Archiving page changes
#3002: Enabled plugins disabled after upgrade
#3009: always provide multipleContexts variable
#3016: supplementary files migration
#3039: editor actions for all managers and sub-editors
#3046: getCustomTemplateKeys parameters
#3051: OAI record datestamp
#3052: consider URL encoding for oai identifiers
#3062: wrong element attributes in oai_marc
#3066: viewPlugin in the plugin gallery for journal managers
#3070: Author names can be exposed to some reviewers
#3072: Prevent range requests
#3080: NavigationMenus - Custom Page Error on Site level
#3087: fix metrics assoc_type for supp files
#3088: File deletion from revision grid is broken
#3106: choose e-mail template when selecting a reviewer
#3108: Duplicated literal
#3114: Select precedent reviewer for a new round failed
#3122: Add copyFile method to SubmissionFileManager
#3141: a string was missed in locale.xml
#3144: NavigationMenus - Warnings removed for custom menuItems

Successfully upgraded to version

Hi @RickMath,

Good, that looks as it should. Continue as per my last couple of posts.

Alec Smecher
Public Knowledge Project Team

OK I enabled the JAMT. the went back and clicked on the admin url and I see the journal page.
Then when I try to go to the Admin url it Firefox fills in the journal path and I go back to the journal page. If I edit the journals table in phpMyAdmin and reset the enabled back to zero then I can go back to the admin page.
The journal home page has no navigation menus and no login dropdown. I have attached two screen shots.

I do not know where! to go next.


OJS Enable 1OJS Enable 2

A little more

When I go to the journal I can see the current journal. If I try to view an article I get a login page. When I log in I can see the pdf. Then I click the back arrow and go back to a page with a menu on the left.
There is a little 0 in the top right menu. Then I go to users and select anpother user and login as that user. I can open a pdf. then in the upper right corner there is a place to logout that user.

I logout as that user and I go back to my page. The upper right menu has View Profile and Logout.

I can now see the screen attached with my papers in my editor role and a menu on the left. Then I can see and manage the submissions.

When I logout I now see a login page. I can login successfully and also I can open the register page.

OJS Enable 3

More discoveries

In the bottom left of the header there is a little down arrow. There is no label. Clicking on it and then moving the mouse down there are three unlabeled but highlighted lines.
The first brings up a page with Home and About the Journal.
The second brings up a Submission page with a place to Login or Register.
The third brings up a Principal Contact page.
There is also a search item on the right. If I open it and type in a name the search takes me to a list of published articles with that name in the authors list.