Translation does not appear but ##workflow.review.externalReview## shown

Hi.

I have done translating ojs 3.0 in Bahasa Melayu (Malay), and because my Translator plugin is not working so I uploaded the translation files manually. Everything is great and working but some words are not display correctly.

Picture below shows variable like ##grid.submission.itemTitles##.

It supposed to show like this, but in Malay it’ll be (Penulis; Tajuk)

But when I look up the translation nothing’s wrong with the code.

Same goes to these variable,

  • grid.preparedEmails.title
  • grid.submission.itemTitle
  • workflow.review.externalReview
  • grid.userGroup.filter.listRoles
  • grid.userGroup.filter.permissionLevel
  • grid.userGroup.allStages

I don’t know where to correct this. Can someone tell me what is the problem here?

Thank you in advance.
Kamaliah.

Hi @kamaliah_yusoff,

Well, if majority of the translations work, then obviously you know how to handle the translations (editing files, locales.xml,…). Could be a problem of caching: try to clear templates cache (Administration - Clear Data Cache). Other option would be the time stamp of the file. That happened to me few times. What you can do is to edit the file (just add space somewhere when it doesn’t affect anything) and save it again so it gets newer timestamp. Hope something helps.

Regards, Primož

1 Like

Hi all,

I’d recommend passing the XML through an XML validator to see if there’s a typo that’s preventing part of the file from being parsed. Most XML editors will do this, and I use xmllint (which should be available for pretty much any platform).

Note, however, that we’ve moved away from using XML files in recent releases – and have switched from the translator plugin over to using Weblate for OJS/OMP/OPS 3.2 and newer. There are tools to convert XML-based translations over to the new .po format, but I’d recommend looking into it before investing a ton of time on your XML files! See Introducing Weblate: a new path for OJS & OMP translations for details.

Regards,
Alec Smecher
Public Knowledge Project Team

1 Like

Hi @primozs ,

Thank you for replying. I will try this solution. If anything happens, I will update here again.

Thank you again,
Kamaliah

Hi,

I’ll try validate the files first. If anything happens I’ll update here.

Thank you again,
Kamaliah.

It works wonderfully! I just did this and also validate the xml files. It turns out great.

Thank you again.
Kamaliah.