The problem with the DOI registration by using the plugin

We have problems with the registration DOI using plug CrossRef Export / Registration Plugin. When I click on the Register button, I am redirected to Home plugin (Figure 1) and Status column is empty (Figure 2).
Whether it is necessary to our server to do something? We are currently using OJS

Fig. 1:

Fig.: 2


hi @aas

Did you see i.e. is there any notification in the right upper corner?


Hi @bozana
When I used a Fire Fox, there was noting, but in I.E I saw:


Hi @bozana,
I am wrong, I tried this operation in Firefox and there was the same notification …


I’am having a similar issue with now. I have already registered with Crossref almost 10 complete issues and now the automatic registration upon publication is not working. Manually I have a different notification error:

Registration was not successful! The DOI registration server returned an error: ‘1 - HTTP/1.1 401 Unauthorized
Access-Control-Allow-Headers: X-Requested-With Access-Control-Allow-Origin: * Www-Authenticate: Basic realm=“restricted area” Content-Type: text/plain Content-Length: 13 Server: http-kit Date: Sat, 16 Apr 2016 09:12:31 GMT Connection: close access denied’.

May this be a problem with the Crossref API ? I didn’t do any changes on the system from the last successful registration.


José Carvalho

Hi @josekarvalho,

This may be an obvious thought – but have you double-checked your CrossRef credentials? Try e.g. logging into the CrossRef website with the same credentials.

Alec Smecher
Public Knowledge Project Team

Hi Alec,

Yes, I login into my crossref account and put again the password on the configuration… and double check :slight_smile:

Looked at the log file and didn’t found anything. I will ask the crossref support if there is any issue.

Hi @bozana,

Any idea, what’s wrong with my registering DOI?
I double checked my credential information and everything looks fine.


Hi all,

This seems a little bit strange – there are 3 Crossref authorization/registration problems in the last time (two in this post and one here: DOI Registration Error using CrossRef)… At the moment I have no idea what’s happening and unfortunately I don’t have an account to test it with, but I will see… and come back to you…


1 Like

Hi, @bozana,

Thank you for answer.
Fortunately Export option works, so we created an XML file and uploaded it on Registration was successful in this way.


@aas, @josekarvalho, @reprabowo,

I was able to register a new article today in Crossref via the built-in API functionality in OJS 2.4.8.

I wonder if you three have anything in common, such as using special characters in the Crossref username/passwords? My successful attempt used an alphanumeric password.

I will try some more testing on my end as well.

1 Like

Dear @ctgraham,

I must confess I am little bit scared…

I just check right now and the two complete issues I try to register last week with Crossref are now working… with the DOI registered…

I just checked right now on Crossef and the information as been successfully registered on friday, one day before posting. My conclusion is that the issue has been successfully sent (even if there was an error)…

Another strange behavior is that these two issues are no more on the list to be sent / registered. But on Saturday, when I put the message on this forum, they where there…

Sorry to put more confusion on this issue, but it may help on the resolution. So @aas and @reprabowo, please check if the DOI are registered now.


José Carvalho


My username is alphanumeric my password has underscore. Is this has caused problem with DOI registration, is it also case sensitive? I will try to change.

I just modified my password and now with no underscore and capital. It works !
Hereunder the image of the articles: First row I submitted the exported XML manually to CrossRef and the rest by using plugin. This is it… the password has special character, but I don’t know about capital letter in password.
Under the Action tab do you think it should be Update rather than Register? and under the status of the manually submitted should be submitted?

This is the last view of the status after I hit Register :blush: and hit Update of the manually submitted article

Hi, @ctgraham,
I use an alphanumeric password, so this is probably not a problem in my case.
Thanks anyway.

Hi, @josekarvalho,

Thanks for the information. Our DOI are registered now, because we submitted the exported XML manually to CrossRef.
But when I click on the Update button in the Action column, I get the same notice:

and in the column Status nothing has changed:

Also when I changed the password on the CrossRef web site, I’m still getting the message: Registration was not successful! The DOI registration server returned an error: ‘1 -’.

In our case it is obviously another error :frowning: .


@aas, the error message with the server returning an error "1 - " is odd, and yet vaguely familiar. The first value here should be an HTTP status code (and “1” doesn’t make sense). The second value should be a response string, which appears to be empty.

Can you confirm that PHP is able to execute an SSL cURL request to Crossref’s server? For example, you could run:

$ch = curl_init('');
$response = curl_exec($ch);
$httpcode = curl_getinfo($ch, CURLINFO_HTTP_CODE);

print '[' . $httpcode . ' - ' . strlen($response)  . ' chars]'."\n";

I wonder if perhaps your cURL is unable to use SSL, or something similar.

Hi, @ctgraham,

Your advice with PHP and CURL helped. Thank you!
Our administrator has added php-curl and able to execute. After that, the Update function on the OJS side had not worked yet. An Update function started to work when I changed password on CrossRef. Then I set the same password again on CrossRef page and it works well under the old password too. Very strange behavior …

Maybe this experience will help someone.


Dear All,

I encountered the same problem.

Any further ideas on where to look for a solution to this problem?

A big thanks to the community. Best wishes from Berlin

@wiebkeberlin, I see you have also posted here:

Please select whichever thread best aligns with what you are seeing, and let us know the details of your experience in that thread.