The file could not be uploaded or revised

After using OJS for sometimes it started giving me this error message “The file could not be uploaded or revised” whenever i want to upload an article. Please any help on how to sort this problem out.

Please post php error log here when you do that.

Did anyone change permissions for data folder?

Also please specify OJS version.

I think i have sorted the problem out by increasing the specifications for subdomains. Thanks to you all.

maybe it is good to report more details here so others can find solution if they have the same issue.

Hi yes, can you describe what your problem was and how you solved it? We are getting this error now along with not being able to add reviewers and a blank administrator page.

I would also like the answer of how it was done, because I am like the same problem.

I was able to solve this problem by increasing the ability to upload files through php.ini

by the terminal:

Search for php.ini file and edit these lines:
If you do not know where the file is:
find / -name php.ini
In my example you would find in apache / php.ini

max_execution_time = 60; maximum execution time of each script, in seconds (def. 30)
max_input_time = 90; maximum amount of time each April script spend review request data (set 60)
memory_limit = 128M; maximum amount of memory an April script consume (def. 128mb)
upload_max_filesize = 200M; maximum size allowed for uploaded files. (Def 2mb)
post_max_size = 180M; maximum size of POST PHP date that will accept.

In our case, setting the maximum file size to be imported is not less than 180MB. This means that we can import via phpMyAdmin database to 180MB.

Having the same problem, I adapted all the information @monicalp gave, but it still is not working for me.
Some days before I also had this problem, today it worked again and now, after working with it for one hour, it fails again.
I use Windows 10. Do you have any other idea what i could try?

I’m trying to resolve the same issue of “the file could not be uploaded or revised” error on OJS

Permissions seem ok, OJS can write to its files, cache, temp and public folder and yet the problem persists.

Are there any specific php libraries required for this to work? Perhaps Vue related?

I am running into this problem too on articles after an upgrade from to, with papers all submitted on the old system. About half happily allow a PDF galley to be uploaded, the rest tell me “could not be uploaded or revised”. This is playing havoc with production as the only workaround I’ve found is to reinitiate submission, which changes the paper number and hence DOI at a time of year when I can’t demand a lot of tech support and it is unfair on my production editor to redo the LaTeX for random submissions (that I hope will allow a resubmit of the galley without breaking).

Any hints on why it should be so horribly misbehaving?

For anyone who runs into this issue, check the permissions of the specific file being replaced. For instance, if the file is owned by root:root, then OJS won’t be able to replace it and you’ll get this error message. File permissions can sometimes get messed up in migrations or bulk imports.

I am facing the same issue. can anyone help?/
Current version: OJS

Dear all

any news about this problem?


selinux was enabled :roll_eyes:

i have the same problem:
1- files not loaded and getting the message “The file could not be uploaded or revised”
2- administration page at the site is not accessible

i found that the hosting account for the journal exceeded the file limit (i.e number of files at the hosting account is too large). i have two options : upgrade or remove unnecessary files, i reduced the number of files at the hosting and every thing was on the correct track (solved).

1 Like

How is the number of files on the hosting reduced?

Have same problem…
“One or more files could not be uploaded.” on Homepage Image
I have different journal on same ojs working fine

Solve the issue… its not only need change to 775 but need change the owner of folder

This topic was automatically closed after 4 days. New replies are no longer allowed.