The current role does not have access to this operation - OMP

I’ve seen this error reported in the forums, but the posts that I’ve looked at don’t seem similar to my problem.

I have some users on a secondary press, which I suspect were imported from the primary press by adding roles to them. When they attempt to add a file to a submission they get this error: ‘The current role does not have access to this operation’.

The users have the following roles:
Chapter Author
Internal Reviewer

The only solution I’ve been able to find is to give them the Production editor role. (Press manager and press editor also work.)

I have also tried giving them Author rights on the primary press, but I still see the same error.

Is allocating the Production editor role a viable workaround, or is there something else I should try?

The Apache error log shows several PHP Warnings, such as:

PHP Warning: array_intersect(): Expected parameter 1 to be an array, null given in /var/www/html/lib/pkp/controllers/grid/queries/ on line 159


Hi @seanc,

Are these two presses on the same installation? Or by imported, did you mean they were imported using the user XML tool?

Kind Regards,

Hi @pmangahis

The presses are on the same installation. By ‘imported’, I mean I searched for users with no roles in the press and then added roles.


Hi @seanc

Thank you for confirming. I have just tested this on the OMP 3.3 test site and was unable to replicate this issue.

Was the Press upgraded from an older version of OMP?

Kind Regards,

Yes, it was originally a installation:

Version Major Minor Revision Build Date installed 3 3 0 7 2021-08-26 3 2 1 2 2020-12-15