Still not being registered with Google Scholar

Upgraded to OMP in June. Still no hits in Google Scholar on any of our books. Google scholar plugin is present and active. Have read the OJS Google Scholar Doc and can’t find anything that helped me understand why our site is not being indexed. Are there any new threads on this? The ones I can find all seem old.

Best regards
Geir Rosset

1 Like

bumping this thread. I also got the same problem… the omp doesnt get index in google scholar… already submit in the google search console and all is good but cannot get index in google scholar.

hope that somebody from the admin team or other user can confirm that google scholar is indexing omp site. because ojs site is easily index in google scholar.

1 Like

yo tambien presento el mismo problema las citas registradas en los metadatos del OMP no se están indexado en Google Scholar ni en POP (publish or perish). Quiero saber como solucionar eso problema

Hello @JairPadilla

Google Scholar works best with indexing OJS, we have a disclaimer on our documentation that it is geared largely toward OJS, and that use of Google Scholar with OMP : Google Scholar Guide

Google Scholar does not index OMP in the same manner it does OJS, this issue is, however, on PKP’s radar: OMP Chapter - Googlescholar support · Issue #7003 · pkp/pkp-lib · GitHub . But if others in the community have had success with this, I’d be interested to hear.

PKP Team

This topic was automatically closed after 5 days. New replies are no longer allowed.