Site Settings Page is Blank (White Page) on new installation

I have newly installed ojs-2.4.7-1.tar version, but on clicking of Site Settings after login, page is blank (White Page). Have tried a lot options to find log or to correct it , but not able to.

Kindly assist.

Hi @ijeditor,

Have you tried this one When I click some button or follow some link, I'm left with a blank page. What do I do? ?

Cheers,
Bruno

Hi Bruno,

Thanks for the information. I have enabled the logs as mentioned in this link. After that I am getting below error in web browser:
Fatal error: Cannot redeclare class UsageStatsReportPlugin in /www/research/plugins/generic/usageStats/UsageStatsReportPlugin.inc.php on line 143

I tried to search about this in Forum, but not able to find any information. Kindly suggest me how can I rectify this issue.

Thanks,

@ijeditor,

It seems there are duplicated files in your installation. The error you have is happening because more than one file is trying to declare the UsageStatsReportPlugin class.

Are you sure you have a clean OJS install?

Cheers,
Bruno

@beghelli,

We have checked, this is our clean installation only. We do not have any other OJS install on our server.
we are getting below error in User Home->Site Administrator->Site Settings:

Fatal error: Cannot redeclare class UsageStatsReportPlugin in /www/research/plugins/generic/usageStats/UsageStatsReportPlugin.inc.php on line 143

I check my scripts.log file as well, finding the same line there:
[02-Feb-2016 04:35:42] PHP Fatal error: Cannot redeclare class UsageStatsReportPlugin in /www/research/plugins/generic/usageStats/UsageStatsReportPlugin.inc.php on line 143

In some of links, on clicking first time, we are getting below error:
500 - Internal Server Error
As we click enter on URL, page loads. This information might help.

Let me know if need any other information to solve this problem or any access…

Thanks for all your help.

The error would not necessarily be that there is another OJS installation, but that there are two files in the existing OJS installation which both identify a “class UsageStatsReportPlugin”.

Did you install this from scratch via the download, or did you upgrade (perhaps via patch)?

Some common ways that you could see an error like this would be:

  • Copying files from Windows a machine to the server where there has been loss of the capitalization of the directory names (e.g. there is a plugins/generic/usageStats and a plugins/generic/usagestats/)
  • Failed upgrading via patch, with the line duplicated, e.g.:
class UsageStatsReportPlugin extends ReportPlugin {
class UsageStatsReportPlugin extends ReportPlugin {

We installed OJS from scratch only and this is not upgrade from patch as well. Right now I have put all code in

if ( !class_exists(‘UsageStatsReportPlugin’) )
{
Code goes here…
}

and it started working. I know this is not the best solution but to make it workable I did it. If you have any other suggestion, please let me know.

Thanks for all your cooperation.

I’d recommend searching your OJS files for the duplicate class definition. You could do this with grep -r 'class UsageStatsReportPlugin' * if you have access to the command line, or in PHP by logging the previously defined class instance.

Finding the duplicate might point to other issues.

1 Like