Shibboleth Plugin in OJS 3


I have some questions concerning the shibboleth plugin in OJS 3.

  1. In multi-journal installations, I can enable the plugin and open the plugin settings on the site (admin) level. In single-journal installations, I cannot enable the plugin on the journal level. I get a notification that the plugin is enabled, but the checkbox is not checked and I cannt access the settings. A bug?

  2. Do I still need to set up the entries in in OJS 3?

  3. The version number does not seem to be correct: shibboleth/version.xml at stable-3_1_2 · pkp/shibboleth · GitHub

  4. In OJS 2, implicit_auth (in could be set to “optional”. ojs/ at ojs-stable-2_4_8 · pkp/ojs · GitHub. Has this option been removed in OJS 3? ojs/ at stable-3_1_2 · pkp/ojs · GitHub


1 Like

Yes, and apparently longstanding one: Plugin tickbox not getting enabled · Issue #3 · pkp/shibboleth · GitHub

I don’t think so. I only see references to plugin settings in the Handler.

Alec bumped this to a 1.0 release in master, but we probably don’t want to package it as a 1.0 release until the above bug is fixed.

Yes, this plugin is “all or nothing” currently.

Thanks, Clinton!

I see a comment on Plugin tickbox not getting enabled · Issue #3 · pkp/shibboleth · GitHub that mentions the issue was closed on the shemgp/ojs_ldap_plugin fork. Will it be brought into the Shibboleth plugin?

There is currently work going on to improve this plugin:

If this bug with enabling the plugin in a single journal instance is still present in the Shibboleth plugin, @lmeerwood might want to be aware of this pitfall.

I have just integrated the fix from the LDAP plugin for single journals into my fork of the Shibboleth plugin. From what I can see with my testing it works fine. I’m about to do a pull request back into the Shibboelth repo.

Are the instructions for Shibboleth updated for OJS?

We have set implicit_auth = On but there is no change on the login page for OJS, and no calls to our Shibboleth install, so we are clearly missing an important step!

Hi @Ian_Caldwell,

I see you’ve also posted about this here:

Let’s continue the conversation there; it’s best not to post the same question in several places, in the interests of keeping the forum organized.

Alec Smecher
Public Knowledge Project Team

1 Like