Reviewer email not working

Hi! I have just installed OJS 2.4.6, so far so good, but I’m having the following problem:
When I add a new reviewer for a manuscript, I enter reviewer details, name, email, etc, then save. The reviewer received the email containing the user name and password.
Then I add the reviewer to the manuscript. But when I click the small envelope icon to send a request for review, the email never reaches the reviewer!
Can you help me with this issue?

Hi @mihai.s,

Is your Article Review Request email template enabled? You can check that under the management pages, at the email templates page. Usually it’s the last entry at page 3 of that list.


There is a button [DISABLE], so I guess it is enabled. When I click the envelope icon, a new page appears with the email generated, the reviewer email address, and at the bottom page I click on SEND icon.


Is this happening with any user or it’s just an specific one? Can you also make sure with the reviewer that the email was not sent to the spam folder of his email?


I have tried this with 2 test accounts, using emails I can control myself.
I also tried to check the “send a copy of the email to myself” box, and I also don’t receive the email.
I tried to cancel the review request, the email does not send.

This is strange, since the used receives the initial email after I set up their account…

I have found the server email log. The last emails had failed with this error:

SMTP error from remote mail server after end of data:
550 Reply-To contains invalid characters.


What is your administrator email? You can check this in the site settings page.


It is my personal email


I think that there is something wrong with your administrator email setting in OJS. The email that’s successfully sent does not use that setting in the reply to field. But the reviewer notification does. And that’s where the problem appears.

Can you try to erase and type again (does not copy from anywhere, just type) your site administrator email and test if the reviewer notification can be sent again?


Same error :frowning:
I have also tried to send a simple email from the list of enrolled users, and it doesn’t work.
Is there any place this reply-to is configured?
in the the force envelope is disabled.

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
; allow_envelope_sender = Off

; Default envelope sender to use if none is specified elsewhere
default_envelope_sender =

; Force the default envelope sender (if present)
; This is useful if setting up a site-wide noreply address
; The reply-to field will be set with the reply-to or from address.
; force_default_envelope_sender = Off

; Enable attachments in the various “Send Email” pages.
; (Disabling here will not disable attachments on features that
; require them, e.g. attachment-based reviews)
enable_attachments = On

; Amount of time required between attempts to send non-editorial emails
; in seconds. This can be used to help prevent email relaying via OJS.
time_between_emails = 3600

; Maximum number of recipients that can be included in a single email
; (either as To:, Cc:, or Bcc: addresses) for a non-priveleged user
max_recipients = 10

; If enabled, email addresses must be validated before login is possible.
require_validation = Off

; Maximum number of days before an unvalidated account expires and is deleted
validation_timeout = 14


The reply to is always filled with the site admin email, so there is no configuration for it.

Can you paste here the [i18n] section of your file? I am not sure, but it seems like an encoding problem to me.



; Default locale
locale = en_US

; Client output/input character set
client_charset = utf-8

; Database connection character set
; Must be set to “Off” if not supported by the database server
; If enabled, must be the same character set as “client_charset”
; (although the actual name may differ slightly depending on the server)
connection_charset = Off

; Database storage character set
; Must be set to “Off” if not supported by the database server
database_charset = Off

; Enable character normalization to utf-8 (recommended)
; If disabled, strings will be passed through in their native encoding
; Note that client_charset and database collation must be set
; to “utf-8” for this to work, as characters are stored in utf-8
charset_normalization = Off

Can it be because my name is Săndulescu, not Sandulescu?
Could it be a problem with the special character ă?
But that is in my name, not in my email address

Ok, usually it’s a good practice to enable the last one, the character normalization. But, as it says there, you should also enable the database charset and set it to the same value of the charset normalization, which is usually utf8.

But before doing that you need to make sure that your database is using utf8. If you’re using MySQL and need help on how to do that, check this link:

Also, try to run this SQL query and paste the result here (make sure that the charset connection is utf8, see

SELECT * FROM site_settings WHERE setting_name = 'contactEmail';

And yes, it could be a problem with the character in your name, as it is also used to form the reply to string. Can you test applying the changes in the config file and making sure your database is using the correct charset?


I don’t know if you received my last message - it doesn’t appear in this list.
I have changed the special character in my name to a simple “a”, and now all the emails work perfectly.
Once again thank you for your prompt answer to my problem!
You are all doing a great job with this project!

Hi @mihai.s,

Thanks for your kind message. It’s good to hear that. And yes, I received your last message, and I replied to that in my previous one. Note that if you have encoding problems, it’s not going to stop until you fix your settings, as I said in my last response.

Your fix is not a good one, since you had to remove a character from your name to make the system to work correctly.