Review cannot submit reviews

Review still not submit. Please advice.

Hi @hussainyousaf,

Check your PHP error log for details.

Regards,
Alec Smecher
Public Knowledge Project Team

@asmecher this error i find in error log and error log not showing after 24-Dec-2019

[24-Dec-2019 01:42:09 UTC] PHP Fatal error: require_once(): Failed opening required ‘plugins/generic/usageStats/GeoLocationTool.inc.php’ (include_path=’.:/opt/cpanel/ea-php70/root/usr/share/pear’) in /home/pjoorgpk/public_html/lib/pkp/classes/plugins/Plugin.inc.php on line 467

@asmecher this error i find in error log and error log not showing after 24-Dec-2019

[24-Dec-2019 01:42:09 UTC] PHP Fatal error: require_once(): Failed opening required ‘plugins/generic/usageStats/GeoLocationTool.inc.php’ (include_path=’.:/opt/cpanel/ea-php70/root/usr/share/pear’) in /home/pjoorgpk/public_html/lib/pkp/classes/plugins/Plugin.inc.php on line 467

@asmecher error_log file not creating log after 24-Dec-2019. How can i check errors?

Hi @hussainyousaf,

There should definitely be something logged… See How do I find my PHP error log? to make sure you’re checking the right file.

Regards,
Alec Smecher
Public Knowledge Project Team

@asmecher these things, please see this and guide accordingly

[14-Feb-2020 08:11:50 UTC] PHP Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 8640 bytes) in /home/pjoorgpk/public_html/index.php on line 65
[14-Feb-2020 08:28:08 UTC] PHP Deprecated: Non-static method ReviewAssignment::getReviewerRecommendationOptions() should not be called statically, assuming $this from incompatible context in /home/pjoorgpk/public_html/lib/pkp/classes/submission/reviewer/form/ReviewerReviewStep3Form.inc.php on line 83
[26-Feb-2020 17:24:04 UTC] PHP Strict Standards: Declaration of ArticleHandler::initialize() should be compatible with PKPHandler::initialize($request) in /home/pjoorgpk/public_html/pages/article/ArticleHandler.inc.php on line 0

Hi @hussainyousaf,

The relevant message is…

 PHP Fatal error: Allowed memory size of 262144 bytes exhausted

That’s a PHP error message, not an OJS one; I’d suggest searching StackOverflow.com for guidance on increasing your PHP memory limit.

Regards,
Alec Smecher
Public Knowledge Project Team

@asmecher We have increase the memory limit of PHP but still problem is there. Screenshot is attached and some logs of 3rd march is below. Please suggest but possible solution because our work is still stop for this problem.

52%20PM

[03-Mar-2020 04:13:39 UTC] PHP Deprecated: Non-static method Request::getContext() should not be called statically, assuming $this from incompatible context in /home/pjoorgpk/public_html/plugins/generic/orcidProfile/OrcidProfilePlugin.inc.php on line 141
[03-Mar-2020 04:13:39 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/pjoorgpk/public_html/classes/core/Request.inc.php on line 68
[03-Mar-2020 04:13:39 UTC] PHP Deprecated: Non-static method Request::getContext() should not be called statically, assuming $this from incompatible context in /home/pjoorgpk/public_html/plugins/generic/orcidProfile/OrcidProfilePlugin.inc.php on line 120
[03-Mar-2020 04:13:39 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/pjoorgpk/public_html/classes/core/Request.inc.php on line 68
[03-Mar-2020 04:13:39 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[03-Mar-2020 04:13:40 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[03-Mar-2020 04:13:40 UTC] PHP Strict Standards: Only variables should be assigned by reference in /home/pjoorgpk/public_html/pages/index/IndexHandler.inc.php on line 68
[03-Mar-2020 04:17:31 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[03-Mar-2020 04:17:32 UTC] PHP Strict Standards: Declaration of ArticleHandler::initialize() should be compatible with PKPHandler::initialize($request) in /home/pjoorgpk/public_html/pages/article/ArticleHandler.inc.php on line 0
[03-Mar-2020 04:17:32 UTC] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/pjoorgpk/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[03-Mar-2020 04:17:32 UTC] PHP Strict Standards: Declaration of SubmissionKeywordEntryDAO::getByControlledVocabId() should be compatible with ControlledVocabEntryDAO::getByControlledVocabId($controlledVocabId, $rangeInfo = NULL, $filter = NULL) in /home/pjoorgpk/public_html/lib/pkp/classes/submission/SubmissionKeywordEntryDAO.inc.php on line 20
[03-Mar-2020 04:17:32 UTC] PHP Deprecated: Non-static method Config::getContextBaseUrls() should not be called statically, assuming $this from incompatible context in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 199
[03-Mar-2020 04:19:35 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[03-Mar-2020 04:19:35 UTC] PHP Strict Standards: Declaration of ArticleHandler::initialize() should be compatible with PKPHandler::initialize($request) in /home/pjoorgpk/public_html/pages/article/ArticleHandler.inc.php on line 0
[03-Mar-2020 04:19:35 UTC] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/pjoorgpk/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[03-Mar-2020 04:19:35 UTC] PHP Deprecated: Non-static method Config::getContextBaseUrls() should not be called statically, assuming $this from incompatible context in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 199
[03-Mar-2020 04:20:31 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[03-Mar-2020 04:20:31 UTC] PHP Strict Standards: Declaration of ArticleHandler::initialize() should be compatible with PKPHandler::initialize($request) in /home/pjoorgpk/public_html/pages/article/ArticleHandler.inc.php on line 0
[03-Mar-2020 04:20:44 UTC] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/pjoorgpk/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[03-Mar-2020 04:20:44 UTC] PHP Strict Standards: Declaration of SubmissionKeywordEntryDAO::getByControlledVocabId() should be compatible with ControlledVocabEntryDAO::getByControlledVocabId($controlledVocabId, $rangeInfo = NULL, $filter = NULL) in /home/pjoorgpk/public_html/lib/pkp/classes/submission/SubmissionKeywordEntryDAO.inc.php on line 20

@asmecher

PHP Fatal error: Class ‘PHPMailer’ not found in /home/pjoorgpk/public_html/lib/pkp/classes/mail/Mail.inc.php on line 463

[04-Mar-2020 08:57:28 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[04-Mar-2020 08:57:28 UTC] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/pjoorgpk/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[04-Mar-2020 08:57:30 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[04-Mar-2020 08:57:30 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[04-Mar-2020 08:57:30 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[04-Mar-2020 08:57:30 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[04-Mar-2020 08:57:30 UTC] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/pjoorgpk/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[04-Mar-2020 08:57:30 UTC] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/pjoorgpk/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[04-Mar-2020 08:57:30 UTC] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/pjoorgpk/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[04-Mar-2020 08:57:31 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[04-Mar-2020 08:57:31 UTC] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24

[Wed Mar 04 14:12:40.162265 2020] [cgi:error] [pid 15758] [client 66.249.93.15:45864] AH01215: PHP Warning: set_time_limit() has been disabled for security reasons in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/acron/PKPAcronPlugin.inc.php on line 220: /usr/local/cpanel/cgi-sys/ea-php56, referer: http://pjo.org.pk/index.php/pjo/issue/view/62
[Wed Mar 04 14:12:38.855508 2020] [cgi:error] [pid 15439] [client 66.249.93.16:47693] AH01215: PHP Warning: set_time_limit() has been disabled for security reasons in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/acron/PKPAcronPlugin.inc.php on line 220: /usr/local/cpanel/cgi-sys/ea-php56, referer: http://pjo.org.pk/index.php/pjo/issue/view/62
[Wed Mar 04 13:35:11.399044 2020] [cgi:error] [pid 2258] [client 46.229.168.163:33336] AH01215: PHP Warning: set_time_limit() has been disabled for security reasons in /home/pjoorgpk/public_html/lib/pkp/plugins/generic/acron/PKPAcronPlugin.inc.php on line 220: /usr/local/cpanel/cgi-sys/ea-php56

Hi @hussainyousaf,

The PHPMailer class (and library) should be included in lib/pkp/lib/vendor/phpmailer/phpmailer; it seems like it’s missing from your installation.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher

Now where i install this file. Please let me know.

Secondly our review process is generating error on screen. Screenshot is attached.

50%20AM

I found this fatal error only in log file

[04-Mar-2020 07:27:20 UTC] PHP Fatal error: Class ‘PHPMailer’ not found in /home/pjoorgpk/public_html/lib/pkp/classes/mail/Mail.inc.php on line 463

[04-Mar-2020 14:12:15 UTC] PHP Fatal error: Call to a member function getId() on null in /home/pjoorgpk/public_html/pages/issue/IssueHandler.inc.php on line 52

Please give us resolution…

I found this fatal error only in log file

[04-Mar-2020 07:27:20 UTC] PHP Fatal error: Class ‘PHPMailer’ not found in /home/pjoorgpk/public_html/lib/pkp/classes/mail/Mail.inc.php on line 463

[04-Mar-2020 14:12:15 UTC] PHP Fatal error: Call to a member function getId() on null in /home/pjoorgpk/public_html/pages/issue/IssueHandler.inc.php on line 52

Please give us resolution…

Secondly, where i install this file. Please let me know.

Secondly our review process is generating error on screen. Screenshot is attached.

50%20AM

Hi @hussainyousaf,

The path that the PHPMailer library should be included in is in my post above. It’s included in the .tar.gz package you downloaded when you installed OJS, so I’d suggest checking if you are missing some files that were included in the package.

Regards,
Alec Smecher
Public Knowledge Project Team

@asmecher But this email function was working acurate 2 weeks ago, now they generating this issue. Please let me know how i extract this file from OJS package?

Secondly this fatal error is also generating

[04-Mar-2020 14:12:15 UTC] PHP Fatal error: Call to a member function getId() on null in /home/pjoorgpk/public_html/pages/issue/IssueHandler.inc.php on line 52

@asmecher Email function was perfect working 2 week ago, 2 week ago we were facing this issue. Please let me know how i extract this file from OJS package?

Secondly this fatal error is also generating

[07-Mar-2020 03:44:33 UTC] PHP Fatal error: Class ‘PHPMailer’ not found in /home/pjoorgpk/public_html/lib/pkp/classes/mail/Mail.inc.php on line 463

[07-Mar-2020 16:36:22 UTC] PHP Fatal error: Call to a member function getId() on null in /home/pjoorgpk/public_html/pages/issue/IssueHandler.inc.php on line 52

Hi @hussainyousaf,

Please let me know how i extract this file from OJS package?

That’s more of a general system administration question than an OJS question. If suggest looking e.g. on StackOverflow.com.

Regards,
Alec Smecher
Public Knowledge Project Team

@asmecher Atleast please give me soultion of these fatal error

[07-Mar-2020 03:44:33 UTC] PHP Fatal error: Class ‘PHPMailer’ not found in /home/pjoorgpk/public_html/lib/pkp/classes/mail/Mail.inc.php on line 463

[07-Mar-2020 16:36:22 UTC] PHP Fatal error: Call to a member function getId() on null in /home/pjoorgpk/public_html/pages/issue/IssueHandler.inc.php on line 52

have you try the solution given by @asmecher? you can access the error log so i asume you have access to the back end of the server.
make sure you have a backup before you try this.

  1. Download the .tar.gz package of your ojs version.
  2. upload it to your directory in the server.
  3. extract the file
  4. go to the directory lib/pkp/lib/vendor/phpmailer/phpmailer and copy the phpmailer folder
  5. go to your jurnal folder
    6 go to lib/pkp/lib/vendor/phpmailer/phpmailer and delete the phpmailer folder
    7 paste the phpmailer folder you copy from the extracted tar.gz .

replace

simple answer is try to replace the phpmailer in your ojs folder (yours is pjoorgpk) from the new one you have just download and extract.

Thanks @mohd_arshad for this help i have done this but this fatal error is still there

[07-Mar-2020 16:36:22 UTC] PHP Fatal error: Call to a member function getId() on null in /home/pjoorgpk/public_html/pages/issue/IssueHandler.inc.php on line 52

and our review process is not working and file is not uploading. Do you have any solution?