Problems with the DOI-CrossRef automatic registration

Hi @lnavarro,

When they updated the OJS code to 2.4.5, this should have included the plugin code.

Unfortunately I’m not sure what to suggest for that error message – it doesn’t appear anywhere in the OJS 2.4.5 codebase that I can see, so I’m not sure where it’s coming from.

Alec Smecher
Public Knowledge Project Team

This message was the Spanish translation of plugins.importexport.crossref.errors.noDOIprefix in 2.3.x:

As @asmecher mentioned, this indicates that your upgrade was not successful.

Backup your database and files, and then try to repair the installation by using the “Full Package” upgrade to ensure all of your files are at 2.4.5.

1 Like

Thank you.
a question: I can only upgrade the plugins without install anew OJS.?
Slds Laura

It is possible to only replace the plugins with the latest versions by just overwriting the “plugins” directory.

I strongly recommend replacing all files, however. You don’t want to have inconsistencies in the code. Right now it appears you have some 2.3.x code in your 2.4.5 install. We found this one instance, but there could be others. It would be best to ensure everything is up-to-date.

Dear All,

I encountered the same problem. It is still possible to register the DOI manually but the OJS CrossRef-Plugin doesn’t register them automatically. I also checked the setttings a few times and made sure to edit the publication date.

Any further ideas on where to look for a solution to this problem?

A big thanks to the community. Best wishes from Berlin

@wiebkeberlin, there have been multiple different issues discussed in the thread above. Can you describe your situation in some more detail?

What version of OJS are you running, and are you using cron or acron to manage the automatic registration? Do you see any errors in the logs or in your email relating to a failure for the automatic registration?

Thanks for your quick reply. I am using version 2.4.8 of OJS. I am not using cron or acron. For a long time the plugin has been working without any problems. We are neither using cron or acron. There has been no error notice send out, I noticed the problem by coincidence. Also when I check the processes it only displays the succesfull manual registration:

{“status”:“ok”,“message-type”:“deposit”,“message-version”:“1.0.0”,“message”:{“handoff”:{“try-count”:1,“delay-millis”:2718.2818284590453,“status”:“completed”,“timestamp”:1462973162732},“dois”:[“10.14512/oew310146”],“parent”:null,“filename”:null,“submitted-at”:“Wed May 11 09:26:02 EDT 2016”,“status”:“completed”,“length”:2607,“content-type”:“application/vnd.crossref.deposit+xml”,“pingback-url”:null,“submission”:{“submission-id”:“1392751891”,“batch-id”:“028d2ef9-7d2b-4450-9f39-dca697978bbd”,“record-count”:1,“success-count”:1,“warning-count”:0,“failure-count”:0,“messages”:[{“status”:“success”,“related-doi”:“10.14512/OEW310146”,“message”:“Successfully updated”,“message-types”:[]}]},“test”:false,“owner”:“oekom”,“batch-id”:“028d2ef9-7d2b-4450-9f39-dca697978bbd”}}

I’m pretty sure that fully automatic registration requires the use of the acron plugin, or the use of cron to run the crossref plugin’s scheduled task.

Either acron or cron should be used in general, as several routine tasks depend on this scheduling.

You can find the acron plugin under User Home → Journal Manager → System Plugins → Generic Plugins - > Acron. There is some older documentation on cron in the OJS 2.3.3 User Guide.

Yes. I found it. We are using the acron plugin.



You seem to have changed the journal abbreviation in the meantime and now you have an invalid character “ö”
in your DOIs. This is probably the reason why the registration fails. The allowed characters are: “a-z”, “A-Z”, “0-9” and “-.;()/". I.e. only ASCII characters are allowed – lets say English alphabet – no special characters except "-.;()/”.


Dear Bozana,

thanks for your post. As far as I can see we had this issue with the DOIs from older issues but not with the most recent ones which failed to register via the plugin. So basically the problem occurred particularly with the most recent issues which contain “oe” instead of “ö”.

But thanks a lot for your help and your ideas!


Could you send a link to an Article with a DOI containing “oe” that couldn’t be registered?


Hi @premolar,

Rather than re-opening an old thread, could you post this issue as a new topic? Also include your OJS version in your posts.

Alec Smecher
Public Knowledge Project Team

Sorry for opening an old topic but no one replies on the new one ><

The crossref plugin is working only if i register the issues or articles manually it only take a second to get register and the username and password are working fine

all the info i read online regarding the requirements for the plugin to work automatically when i publish an issue or article are met…

yet whenever i give it a try it always give me ( not deposit ) status

I tried it with Acron plugin enabled and tried to reload schedules and tried it with Acron off
Tried to change the password and make it only alphanumeric with no capitals
i have the schedule turned on from the

I have tried everything but still not working … do u have any suggestions?

There is a known bug in 2.4.x where the deposit status within the Crossref plugin will not progress, even though the article is successfully registered with Crossref. This status progression was rewritten in 3.x:

Can you confirm whether the issue is just a failure of updating the deposit status, or a failure of registering the DOI?

1 Like

No it doesn’t submit at all i keep checking the Crossref website and the doi itself doesn’t work … i have to click on the register button manually from the crossref plugin then it works fine

but when i publish it even tho the DOI is assigned, the username and pass are correct and all other requirements are met … nothing happens

i tried to enable and disable tha Acron plugin but nothing happened also…

and i don’t get any errors… it’s just not deposit there is no attempt to deposit the doi

What appears in your scheduled task log for this task? In your files_dir you should find files like scheduledTaskLogs/CrossRefautomaticregistrationtask-<md5hash>-<yyyymmdd>.log

For what dates do you see log files, and what is the contents of those logs?

I’m sorry for the stupid question but where can i find these log files?.. I’m new to all this to be honest

I tried to run the file plugins/importexport/crossref/CrossrefInfoSender.php manually to see if it will work and register the unregistered DOIs or not… i got an error in line 16

I looked in my OJS directory and found that lib/pkp/ is empty
so i downloaded the pkp library there

i tried to run it again and got the same error

am i doing something wrong?>

I tried to run the

It gave me an error in the line trying to call the library

Tried to run

Also got an error in the first class line

Can anyone help?