Problema para enviar correos con gmail

Que tal comunidad, quisiera ver si alguien me puede guiar con la solución de este problema que se presenta actualmente con el envío de correos con una cuenta de gmail configurada en el config.inc.php, esto según la configuración que se sugiere en la documentación oficial de OJS todo funcionaba bien, pero en esta semana ha surgido el problema que los correos no se están enviando, revisando he encontrado que las políticas de gmail han cambiado con respecto al manejo de aplicaciones de terceros, agradezco cualquier ayuda al respecto.

Configuración config.inc.php

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = smtp.gmail.com
smtp_port = 587

; Enable SMTP authentication
smtp_auth = tls
smtp_username = "user@gmail.com"
smtp_password = "password"

hola @jarulin

Como bien indica gmail ha cambiado las políticas de autenticación, sobre todo, para quitarse de encima clientes de correo o código que ellos no controlan. Algunos clientes de correo incluso han parado el desarrollo por negarse a acatar la nueva autenticación.

Es lo de siempre, ahora que han ganado una amplia cuota de mercado ofreciendo productos gratuitos, empiezan a cerrar.

¿No tiene posibilidad de sacar el correo por el servidor SMTP donde aloja OJS?

Gracias

1 Like

@juanito gracias por tu respuesta, la verdad me sirve mucho, lo he solucionado claro definitivamente me toco dejar de usar esa cuenta y usar una con el dominio de la organización y como bien mencionas usando recursos propios para gestionar el envio del correo, lo que si he cambiado el config.inc.php adjunto abajo las configuraciones para que le sirva a alguien más.

Configuración de config.inc.php

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = smtp.xxxx.com
smtp_port = 587

; Enable SMTP authentication
smtp_auth = tls
smtp_username = user@xxxx.com
smtp_password = password

allow_envelope_sender = On

default_envelope_sender = user@xxxx.com

force_default_envelope_sender = On

force_dmarc_compliant_from = On

time_between_emails = 3600

max_recipients = 10

require_validation = On

validation_timeout = 14
2 Likes

Hola yo tuve el mismo problema, uso gmail para enviar los correos, la forma que yo encontré para solucionar es activar la verificación de 2 pasos de Gmail, activar una contraseña para App, la generas con un nombre y luego en el config.inc.php, se sustituye por la que tenías anteriormente.
smtp_username = user@gmail.com
smtp_password = password16digitos

1 Like