Plugin Gallery keeps loading but nothing shown

Description of issue or problem I’m having:
I am using the lastest version of OJS In the past few days, I succeeded in activating plugins from “installed plugins” and installing plugins from the plugin gallery. But yesterday, when I tried installing more interesting plugins again, it shows this wheel all the time.2021-10-01-10-19-41

I checked Network, I found there is one red line, status 500:$$$call$$$/grid/plugins/plugin-gallery-grid/fetch-grid?_=1633054336781

Hi @bluecover

We had a systems issue yesterday related to an SSL certificate. It has been resolved and the plugin gallery should be working again.


Thank you very much for your efforts and for letting me know this. However, it still doesn’t work on my side. I reboot my instance and cleared the cache on the administration page. Then I cleared the cache in chrome, but the wheel is still rounding.
Maybe I should wait a little longer?

Hi @bluecover

I can definitely confirm that the plugin gallery tab is now correctly loading on our on hosted journals on our servers. The plugin gallery works by having OJS fetch an XML file using a PHP code library, and if that fetch fails for some reason the wheel will continue to spin. It might be worth asking your systems admin to verify that your server hosting OJS isn’t caching a stale SSL certificate.


As a follow up I wanted to also suggest that you update the cacert.pem file on your server, with the one available here:

That file is used by curl and Guzzle to verify certificates and it contains an R3 intermediate certificate, which was the problematic one that expired yesterday. The cert file was updated quite a while ago but if your server still has an old one it might be the cause of the problem.


Thanks for all this information.
I changed my SSL certificate. Then, I tested whether my server uses an R3 certificate through this URL: It said no. However, the wheel still spins.
I will contact my admin and check what happens to my server.

Hi @bluecover

My apologies if I was unclear - I wasn’t referring to the SSL certificate that your own server used, but rather that it might have a cached certificate for us or rather, a cached intermediate, generally.


Hi @bluecover You must update in your server the package ca-certificates. If your server has CentOS or a derivate you can use the command in console

yum update ca-certificates

If you server is based on Debian the console command is

apt-get install --only-upgrade ca-certificates


@yasielpv @jnugent Thank you soooooo much to both of you! That finally works!
For others who may encounter the same issue as me, I suggest inputting this line first to get root permission.

sudo su

Then, as @yasielpv suggested, this magic line:

yum update ca-certificates

When it’s done, the command screen is like this:

And my plugin gallery finally works:

1 Like

Hi! @yasielpv @asmecher @rcgillis
I am behind a proxy server and I have already updated the certificates, my gallery keeps loading, what else could it be?
ojs version: 3.3.0-10

Proxy config in
; The HTTP proxy configuration to use
; http_proxy = “http://username:password@
; https_proxy = “https://username:password@

http_proxy = “
https_proxy = “

Mmmmm I found this in the log:

PHP Fatal error: Uncaught GuzzleHttp\Exception\ConnectException: cURL error 35: error:1408F10B:SSL routines:ssl3_get_record:wrong version number (see in /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php:200\nStack trace:\n#0 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(155): GuzzleHttp\Handler\CurlFactory::createRejection()\n#1 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(105): GuzzleHttp\Handler\CurlFactory::finishError()\n#2 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlHandler.php(43): GuzzleHttp\Handler\CurlFactory::finish()\n#3 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/Proxy.php(28): GuzzleHttp\Handler\CurlHandler->__invoke()\n#4 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/Proxy.php(51): GuzzleHttp\Handler\Proxy::GuzzleHttp\Handler\{closure}()\n#5 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/PrepareBodyMiddlewar in /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 200, referer:

Hi @Sunny, in your config, change the https_proxy variable to
https_proxy = “”
without the s in the protocol of the value

http_proxy = “”
https_proxy = “”

1 Like

Ooooohhh That worked, thanks mate!!!

I have another problem, my html galleys come out blank


Hi @Sunny, your solution for that is here