Php error in ojs 3.0.2.0

ojs3
#1

Hi

I recently updated my ojs to version 3.0.2.0. When I try to submit an article, it is showing me “php error” when uploading the corresponding file. I appreciate any collaboration to solve this problem.

The php error_log file say “[Tue Jul 11 17:59:03.912190 2017] [:error] [pid 9785] [client 66.249.64.17:40054] PHP Warning: Illegal string offset ‘es_ES’ in /var/www/html/lib/pkp/classes/core/DataObject.inc.php on line 133”

#2

Hi @fforerogarcia,

Can you show a screenshot of the page showing the “php error”? It sounds to me like a fatal (500) error, but the log entry you showed is only a warning. (Is there anything else relevant in the log?)

Regards,
Alec Smecher
Public Knowledge Project Team

I Can install OJS 3.X on Ubuntu 16.04 PHP7
#3

Hi
Thanks for your reply. The attached file contains the error message.

#4

I was able to correct the error. It was solved by giving write permissions to the “files” directory. (error 500)
Thanks for your help.